Bug 182383 - FC4 Sound card stops working after upgrade
FC4 Sound card stops working after upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 23:37 EST by Keith Miller
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 06:07:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsound.log from Sound Card detect (11.70 KB, text/plain)
2006-02-21 23:37 EST, Keith Miller
no flags Details
Log file (11.43 KB, text/plain)
2006-02-25 10:59 EST, Keith Miller
no flags Details
Log file (11.43 KB, text/plain)
2006-02-25 11:00 EST, Keith Miller
no flags Details
Log file (11.42 KB, text/plain)
2006-02-25 11:01 EST, Keith Miller
no flags Details
Log file (11.43 KB, text/plain)
2006-02-25 11:01 EST, Keith Miller
no flags Details

  None (edit)
Description Keith Miller 2006-02-21 23:37:24 EST
Description of problem:

Sound on IBM T42p Laptop stopped working after kernel upgrade to:
 2.6.15-1.1831_FC4 #1 Tue Feb 7 13:37:42 EST 2006 i686 i686 i386 GNU/Linux

I have been running 2.6.14-1.1656_FC4, 2.6.14-1.1653_FC4, and 2.6.11-1.1369_FC4
with no problems. After the "yum update" to the 2.6.15-1 kernel I don't get any
sound.

Running sound card detection looks like it works, but still no sound.

However, when you plug and unplug the power plug the laptop "beeps".

How reproducible: Constant ...

Steps to Reproduce:
1. Install FC4 on an IBM T42p 
2. Play a sound file ... (works)
3. Do a Yum -y update to the latest and greatest
4. Try to play a sound file ... (fails!)

  
Attached is the scsound.log from the sound card detect
Comment 1 Keith Miller 2006-02-21 23:37:25 EST
Created attachment 125005 [details]
scsound.log from Sound Card detect
Comment 2 Martin Stransky 2006-02-23 08:05:47 EST
Could you enable dnix/dsnoop in system-config-soundcard and check it again? Or
you can check the "External amplifier" switch in alsamixer (a command line
utility)...
Comment 3 Keith Miller 2006-02-25 10:59:46 EST
Created attachment 125250 [details]
Log file
Comment 4 Keith Miller 2006-02-25 11:00:51 EST
Created attachment 125251 [details]
Log file
Comment 5 Keith Miller 2006-02-25 11:01:17 EST
Created attachment 125252 [details]
Log file
Comment 6 Keith Miller 2006-02-25 11:01:40 EST
Created attachment 125253 [details]
Log file
Comment 7 Keith Miller 2006-02-25 11:04:19 EST
Hi Martin,

I've attached 4 log files (probably did it wrong, trying to work out BugZilla!).

I've tried all the combinations with dnix/dsnoop ticked and not ticked, for the
two sound card entries that appear.

I've also tried the external amplifier settings on alsamixer.

Still not a peep out of it!

Regards

Keith
Comment 8 Martin Stransky 2006-02-27 09:32:27 EST
You can check the latest drivers, how-to is here:
http://people.redhat.com/stransky/alsa/
Comment 9 Martin Stransky 2006-02-27 09:39:19 EST
btw. you can check the old-driver, too. It was 1.0.9 and you can find it on
http://www.alsa-project.org. Instalation steps are the same as above...
Comment 10 Keith Miller 2006-03-16 02:23:45 EST
Hi,

I've tried to build the 1.0.9 driver, but I get a great list of errors. the
1.0.10 driver builds and installs, just does not work!!!

I've played with it, but I'm not getting anywhere, so I've kinda decided to hang
out for FC5 next week and do a full install.

Thanks

Keith
Comment 11 Martin Stransky 2006-03-30 04:18:57 EST
On my how-to page are new packages for ALSA 1.0.11rc4, you can check it...

Note You need to log in before you can comment on or make changes to this bug.