Bug 182383 - FC4 Sound card stops working after upgrade
Summary: FC4 Sound card stops working after upgrade
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib   
(Show other bugs)
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-22 04:37 UTC by Keith Miller
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 10:07:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsound.log from Sound Card detect (11.70 KB, text/plain)
2006-02-22 04:37 UTC, Keith Miller
no flags Details
Log file (11.43 KB, text/plain)
2006-02-25 15:59 UTC, Keith Miller
no flags Details
Log file (11.43 KB, text/plain)
2006-02-25 16:00 UTC, Keith Miller
no flags Details
Log file (11.42 KB, text/plain)
2006-02-25 16:01 UTC, Keith Miller
no flags Details
Log file (11.43 KB, text/plain)
2006-02-25 16:01 UTC, Keith Miller
no flags Details

Description Keith Miller 2006-02-22 04:37:24 UTC
Description of problem:

Sound on IBM T42p Laptop stopped working after kernel upgrade to:
 2.6.15-1.1831_FC4 #1 Tue Feb 7 13:37:42 EST 2006 i686 i686 i386 GNU/Linux

I have been running 2.6.14-1.1656_FC4, 2.6.14-1.1653_FC4, and 2.6.11-1.1369_FC4
with no problems. After the "yum update" to the 2.6.15-1 kernel I don't get any
sound.

Running sound card detection looks like it works, but still no sound.

However, when you plug and unplug the power plug the laptop "beeps".

How reproducible: Constant ...

Steps to Reproduce:
1. Install FC4 on an IBM T42p 
2. Play a sound file ... (works)
3. Do a Yum -y update to the latest and greatest
4. Try to play a sound file ... (fails!)

  
Attached is the scsound.log from the sound card detect

Comment 1 Keith Miller 2006-02-22 04:37:25 UTC
Created attachment 125005 [details]
scsound.log from Sound Card detect

Comment 2 Martin Stransky 2006-02-23 13:05:47 UTC
Could you enable dnix/dsnoop in system-config-soundcard and check it again? Or
you can check the "External amplifier" switch in alsamixer (a command line
utility)...

Comment 3 Keith Miller 2006-02-25 15:59:46 UTC
Created attachment 125250 [details]
Log file

Comment 4 Keith Miller 2006-02-25 16:00:51 UTC
Created attachment 125251 [details]
Log file

Comment 5 Keith Miller 2006-02-25 16:01:17 UTC
Created attachment 125252 [details]
Log file

Comment 6 Keith Miller 2006-02-25 16:01:40 UTC
Created attachment 125253 [details]
Log file

Comment 7 Keith Miller 2006-02-25 16:04:19 UTC
Hi Martin,

I've attached 4 log files (probably did it wrong, trying to work out BugZilla!).

I've tried all the combinations with dnix/dsnoop ticked and not ticked, for the
two sound card entries that appear.

I've also tried the external amplifier settings on alsamixer.

Still not a peep out of it!

Regards

Keith


Comment 8 Martin Stransky 2006-02-27 14:32:27 UTC
You can check the latest drivers, how-to is here:
http://people.redhat.com/stransky/alsa/

Comment 9 Martin Stransky 2006-02-27 14:39:19 UTC
btw. you can check the old-driver, too. It was 1.0.9 and you can find it on
http://www.alsa-project.org. Instalation steps are the same as above...

Comment 10 Keith Miller 2006-03-16 07:23:45 UTC
Hi,

I've tried to build the 1.0.9 driver, but I get a great list of errors. the
1.0.10 driver builds and installs, just does not work!!!

I've played with it, but I'm not getting anywhere, so I've kinda decided to hang
out for FC5 next week and do a full install.

Thanks

Keith


Comment 11 Martin Stransky 2006-03-30 09:18:57 UTC
On my how-to page are new packages for ALSA 1.0.11rc4, you can check it...


Note You need to log in before you can comment on or make changes to this bug.