Bug 182457 - Installer crashes on mac mini
Installer crashes on mac mini
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 12:40 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 17:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Syslog from install (57.70 KB, text/plain)
2006-08-14 16:30 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2006-02-22 12:40:35 EST
Description of problem:
Booted from the CD.  After clicking on the "Install anyway" button the installer
crashes and the system shuts down.
Comment 1 Paul Nasrat 2006-02-22 13:15:16 EST
Please define the crash including what is printed to screen in more detail, the
bug report does not contain sufficient information to diagnose.  In addition
please report all steps taking up to this moment.  I've done ppc installs on a
variety of hardware without seeing this.
Comment 2 Orion Poplawski 2006-02-22 14:08:26 EST
Well, there's not much info, but:

- Boot to cdrom.  Press return to get default startup
- System boots
- Select English, us keyboard
- Select NFS source and enter server and path
- Use DHCP
- Anaconda starts.  Click Next, Click Install Anyway

Here the install aborts.  Back to the "Blue Screen" with:

Running anaconda...
Probing for video card:  ATI Technologies Inc RV280 [Radeon 9200]
Probing for monitor type: VA520-2
Attemping to start native X server
Waiting for X server to start... log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.
Starting graphical installation...
install exited abnormally
sending termination signals...done
sending kill signals...done
...
you may safely reboot system.



Also, twice now afterwards the boot has hung at:

Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected Apple UniNorth 2 chipset
agpgart: configuring for size idx: 4
agpgart: AGP aperture is 16M @ 0x0

power cycle gets it booting again.

Comment 3 Paul Nasrat 2006-02-22 14:11:51 EST
If you boot with linux nokill you may be able to switch to tty3 and tty4 post
the error to see more.
Comment 4 Orion Poplawski 2006-02-22 16:03:19 EST
On tty3, the only error is:

ERROR: failed to loading mousedev module

last entries are:

INFO: moving (1) to step welcome
INFO: moving (1) to step betang
INFO: moving (1) to step findrootparts

tty4:
<3>Debug: sleeping function called from invalid context at
arch/powerpc/kernel/traps.c:700
<4>in_atomic():0, irqs_disabled():1
<4>Call Trace:
<4>[DEAA3EC0] [C0007A64] show_stack+0x54/0x184 (unreliable)
<4>[DEAA3EE0] [C002B07C] __might_sleep+0xbc/0xd0
<4>[DEAA3EF0] [C000E4CC] program_check_exception+0x218/0x510
<4>[DEAA3F40] [C000FB58] ret_from_except_full+0x0/0x4c
<4>--- Exception: 700 at 0xf29318c
<4>    LR = 0x5293184
<4>program anaconda is using a deprecated SCSI ioctl, please convert it to SG_IO
<4>program anaconda is using a deprecated SCSI ioctl, please convert it to SG_IO

note that I believe all of these are display well before the crash.

Is there a way to check the check media function to run earlier?
Comment 5 Orion Poplawski 2006-02-22 17:00:29 EST
Trying with today's rawhide, anaconda crashes:

Traceback:
 File "/usr/bin/anaconda", line 1108, in ?
    from yuminstall import YumBackend
 File "/usr/lib/anaconda/yuminstall.py", line 427
    if self.tsInfo.reqmedia = {}:
                            ^

SyntaxError: invalid syntax
Comment 6 Chris Lumens 2006-02-23 10:28:49 EST
The SyntaxError traceback has been fixed in today's Rawhide.  Please test with
that and see if you are still seeing the crash after clicking "Install anyway".
 The other message you're seeing on tty4 with the call trace should be filed
against the kernel.
Comment 7 Orion Poplawski 2006-02-23 11:53:15 EST
SyntaxError is indeed fixed.  Now I'm back to the original crash.

Ok - found the culprit.  I had a firewire drive attached to the system.  I
removed that, and I can continue with the installation fine.
Comment 8 Paul Nasrat 2006-02-23 11:59:53 EST
What is the partition table on the firewire drive, if you connect it on the
running system do you get an oops/error loading?
Comment 9 Orion Poplawski 2006-02-23 12:11:54 EST
Works fine on my FC4 install:

Feb 23 10:12:02 mini ieee1394.agent[3118]: ... no drivers for IEEE1394 product
0x/0x/0x
Feb 23 10:12:02 mini ieee1394.agent[3133]: ... no drivers for IEEE1394 product
0x/0x/0x
Feb 23 10:12:02 mini ieee1394.agent[3143]: ... no drivers for IEEE1394 product
0x/0x/0x
Feb 23 10:12:02 mini ieee1394.agent[3148]: ... no drivers for IEEE1394 product
0x000000/0x0010b9/0xceb001
Feb 23 10:12:02 mini kernel: sbp2: $Rev: 1306 $ Ben Collins <bcollins@debian.org>
Feb 23 10:12:02 mini kernel: ieee1394: sbp2: Driver forced to serialize I/O
(serialize_io=1)
Feb 23 10:12:02 mini kernel: ieee1394: sbp2: Try serialize_io=0 for better
performance
Feb 23 10:12:02 mini kernel: scsi0 : SCSI emulation for IEEE-1394 SBP-2 Devices
Feb 23 10:12:03 mini kernel: ieee1394: sbp2: Logged into SBP-2 device
Feb 23 10:12:03 mini kernel:   Vendor: Maxtor    Model: OneTouch II       Rev: 0244
Feb 23 10:12:03 mini kernel:   Type:   Direct-Access                      ANSI
SCSI revision: 04
Feb 23 10:12:03 mini kernel:  0:0:1:0: Attached scsi generic sg0 type 0
Feb 23 10:12:03 mini kernel: SCSI device sda: 398297088 512-byte hdwr sectors
(203928 MB)
Feb 23 10:12:03 mini kernel: sda: cache data unavailable
Feb 23 10:12:03 mini kernel: sda: assuming drive cache: write through
Feb 23 10:12:03 mini kernel: SCSI device sda: 398297088 512-byte hdwr sectors
(203928 MB)
Feb 23 10:12:03 mini kernel: sda: cache data unavailable
Feb 23 10:12:03 mini kernel: sda: assuming drive cache: write through
Feb 23 10:12:03 mini kernel:  sda: [mac] sda1 sda2 sda3 sda4 sda5 sda6 sda7 sda8
sda9 sda10
Feb 23 10:12:04 mini kernel: sd 0:0:1:0: Attached scsi disk sda
Feb 23 10:12:04 mini scsi.agent[3210]: disk at
/devices/pci0002:20/0002:20:0e.0/fw-host0/0010b9210080041f/0010b9210080041f-1/host0/target0:0:1/0:0:1:0
Feb 23 10:12:06 mini fstab-sync[3289]: added mount point /media/Mini_Backup for
/dev/sda3
Feb 23 10:12:06 mini fstab-sync[3303]: added mount point /media/Raffles_Backup
for /dev/sda5
Feb 23 10:12:07 mini fstab-sync[3320]: added mount point /media/Eagle_Backup for
/dev/sda9
Feb 23 10:12:07 mini fstab-sync[3324]: added mount point /media/Nomad_Backup for
/dev/sda7

(parted) print
Disk geometry for /dev/sda: 0.000-194481.000 megabytes
Disk label type: mac
Minor    Start       End     Filesystem  Name                  Flags
1          0.000      0.031              Apple
3        128.031  16084.925  hfs+        Apple_HFS_Untitled_2
5      16212.926  70188.667  hfs+        Apple_HFS_Untitled_3
7      70316.668 146226.351  hfs+        Apple_HFS_Untitled_4
9     146354.352 194480.992  hfs+        Apple_HFS_Untitled_5
Comment 10 Chris Lumens 2006-08-14 13:14:16 EDT
Is this better in FC6t2?
Comment 11 Orion Poplawski 2006-08-14 16:30:52 EDT
Created attachment 134165 [details]
Syslog from install

Well, it's continuing, but I think it's because it just doesn't see the
firewire drive at all now.  I've attached the syslog output for more info, but
I definitely don't have a /dev/sda anymore.

Note You need to log in before you can comment on or make changes to this bug.