Bug 182471 - Video corruption, ATI Radeon 7000 and ES1000 - Display Engine stops issuing MC requests.
Video corruption, ATI Radeon 7000 and ES1000 - Display Engine stops issuing M...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
: 182472 (view as bug list)
Depends On:
Blocks: 176344 198694 200936 201798
  Show dependency treegraph
 
Reported: 2006-02-22 14:42 EST by Rod Macdonald
Modified: 2009-06-18 10:47 EDT (History)
14 users (show)

See Also:
Fixed In Version: xorg-x11-6.8.2-1.EL.13.36
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-24 15:33:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rod Macdonald 2006-02-22 14:42:24 EST
This problem was originally reported by Dell.  

Occasionally, on startx, badly corrupted video is displayed completely 
obscuring the desktop.  Ctrl-Alt-Bksp does not resolve the problem - the 
resulting text session remains corrupted.  This has been seen at 1024x768 and 
1280x1024 but it is more prevalent at higher resolutions - it occurs about 20% 
of the time at 1920x1400,24bpp@60Hz when using ES1000 with 200MHz vRAM.  

ATI has determined that the problem is caused by a FIFO which fills, stalling 
the display controller.  This occurs when the memory controller (MC) attempts 
to send transactions to system memory that were intended for the video frame 
buffer.  There is a window of opportunity where the frame buffer address in 
MC_FB_Location differs from the display engine registers.  

There is now a WIP fix available at:
https://bugs.freedesktop.org/show_bug.cgi?id=5916.  

The fix will replace xorg-x11-6.8.1-ati-radeon-RV100-bus-master-fix.patch from 
RH Bug# 165179.  Disabling bus mastering is no longer necessary since the "bad 
transactions" are now stopped closer to the source.

This fix is also mentioned in RH Bug 180150.  

Can you provide a target release for Dell?
Comment 1 Mike A. Harris 2006-03-08 02:44:32 EST
(In reply to comment #0)
> This problem was originally reported by Dell.

Can you provide the Dell bug report ID, so we can synchronize.

 

> There is now a WIP fix available at:
> https://bugs.freedesktop.org/show_bug.cgi?id=5916  

I've discussed this a bit with Michel Daenzer this week also.  It seems there
are still some issues with this patch which need to be resolved.  Do you have
an estimate of when an updated patch might be available?


 ------- Additional comment #3  from Michel Dänzer on 2006-02-23 19:05  [reply]
-------

The current patch has been reported to hang on some systems, see
https://bugzilla.novell.com/show_bug.cgi?id=151631 . This is being investigated.



> The fix will replace xorg-x11-6.8.1-ati-radeon-RV100-bus-master-fix.patch from 
> RH IT_77281.  Disabling bus mastering is no longer necessary since the "bad 
> transactions" are now stopped closer to the source.
> 
> This fix is also mentioned in RH Bug 180150.  
> 
> Can you provide a target release for Dell?

During the RHEL4 U4 update cycle, we can create test packages, however it
would be strongly preferred to see the problems reported resolved first.

We do not want to risk destablizing the driver further in an official
update, until all issues have been resolved.

Thanks in advance.
Comment 2 Mike A. Harris 2006-03-09 05:07:17 EST
Ugh, this bug was filed twice, and people are picking one at random when
updating them.
Comment 3 Mike A. Harris 2006-03-09 05:09:10 EST
*** Bug 182472 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2006-03-09 05:10:00 EST
Comment #2 From Samuel Benjamin (sbenjamin@redhat.com)  	 on 2006-02-23 11:07
EST  	[reply]  	 Private

I see there are some issues with this patch upstream. Can ATI  investigate and
post a response with the correct patch ?

-----------------------------
https://bugs.freedesktop.org/show_bug.cgi?id=5916#c3
 ------- Additional comment #3  from Michel Dänzer on 2006-02-23 19:05  [reply]
-------

The current patch has been reported to hang on some systems, see
https://bugzilla.novell.com/show_bug.cgi?id=151631 . This is being investigated.
-----------------------------
Comment 5 Rod Macdonald 2006-04-11 16:09:15 EDT
Mike, I see the ATI fix for this bug on freedesktop has been nominated for the 
6.8 branch.  Is this sufficient for Redhat to accept the fix?
Comment 8 Mike A. Harris 2006-04-25 10:59:54 EDT
(In reply to comment #5)
> Mike, I see the ATI fix for this bug on freedesktop has been nominated for the 
> 6.8 branch.  Is this sufficient for Redhat to accept the fix?

The patch has already been included in our test builds for some time now,
and there have not been any regressions reported in roughly a month.

This appears to be a duplicate of bug #177057.  Both bugs have been
ACK'd by devel, but not by QA.  I will attempt to shepherd this one
through our exception criteria procedure.
Comment 14 Rod Macdonald 2006-05-24 10:59:21 EDT
Hi Mike, 
Can you confirm that this fix did get to RHEL4 U4.  Thanks,
Comment 15 Mike A. Harris 2006-06-02 15:52:10 EDT
The existing patch that we already had was updated to include the new
changes, and packages were made available then and a request for testing
made.  There wasn't any response to the request for testing so it
was assumed that everything works ok as no problems were discovered
internally, so it will be included in U4.

The bug is closed now in ON_QA state pending testing by our QA department.
Once that has been completed and the erratum released, the bug will
transition to "ERRATA" state.

Hope this helps.
Comment 22 John Poelstra 2006-07-14 20:43:03 EDT
re: comment #20 moving this bug to ASSIGNED and removing from
http://errata.devel.redhat.com/errata/showrequest.cgi?advisory=3850
Comment 24 Samuel Benjamin 2006-08-01 13:41:37 EDT
There seems to have been some QA fallout indicating that some video corruption
existed and hence this patch seems to have not made U4.

Comment #16 in BZ
With an ATI 7200 on an i386 machine, I occasionally see corruption. Switching to
the console and back again does seem to fix it, though.

Comment 25 Larry Troan 2006-08-09 11:01:42 EDT
Fix pulled from RHEL4 Update4 because patch did not fix problem. Will consider
for RHEL4 Update5.
Comment 26 Samuel Benjamin 2006-08-30 13:57:26 EDT
Rod (ATI), 
Please address the comments from QA that indicate there is still somne video
corruption after this patch was implemented. This was the reason why it was
pulled from U4. We need to address this soon to make sure it wil be included in 4.5.
Comment 28 Xin-Yun Liu (Wolke Liu) 2006-09-01 09:04:37 EDT
to Comment #24 From Samuel Benjamin (sbenjamin@redhat.com)
I have not duplicated video corruption yet on RH4U4(xorg-x11-6.8.2-
1.EL.13.36.src.rpm). 

what is the symptom of video corruption? Is it just splashed? If so,it may be 
caused by the garbage in the memory due to the address is changed. And it could 
be fixed by clear the memory content before redraw the window. Otherwise, wish 
no otherwise.
Comment 31 Issue Tracker 2006-09-20 20:10:20 EDT
Need response from engineering on validity of patch and inclusion into
4.5.

Comment #30
Zack Cerza (zcerza@redhat.com),
ATI confirms that the patch is good and should resolve the video corrupton
problem . They cannot reproduce it in their testing. Can you respond to
ATI's comments so they can work on fixing their patch if any video
corruption still exists?


This event sent from IssueTracker by sbenjamin 
 issue 88684
Comment 33 Larry Troan 2006-09-28 09:11:29 EDT
Opening commment #31 so ATI can view it and respond as requested.....
Comment 34 Larry Troan 2006-09-28 09:42:37 EDT
Correction. Dell needs to review comment #31 and comment back to ATI as
requested as to the effectiveness of the patch.

Do we need a people.page kernel/xorg for Dell to test with?
Comment 35 Larry Troan 2006-11-14 13:03:00 EST
Dell....PING.... NEEDINFO on this bug since 9-28-06 per comment #34 above.
Comment 36 Charles Rose 2006-11-30 04:43:31 EST
(In reply to comment #34)
> Correction. Dell needs to review comment #31 and comment back to ATI as
> requested as to the effectiveness of the patch.
> 
> Do we need a people.page kernel/xorg for Dell to test with?

It would help if we got a test package rpm from a people page.
Comment 37 Samuel Benjamin 2006-12-14 07:57:03 EST
Dell is requesting a test package to tet with. Also please post the patch that
ATI has suggested to this bug. Thanks.
Comment 38 Søren Sandmann Pedersen 2007-01-10 16:40:57 EST
Comments to the contrary notwithstanding, I believe the problem here *was* in
fact fixed in U4. There was some concern that corruption was still present on a
Radeon 7200, but the patch was never dropped, and from the description it
doesn't sound like that corruption is necessarily related.

So I have a simple question: Does Dell in fact see this problem in U4?
Comment 39 Charles Rose 2007-01-17 02:39:37 EST
Dell will test with RHEL4.4 to verify if this issue is infact fixed.
Comment 40 Charles Rose 2007-01-24 09:14:51 EST
This issue has been fixed in RHEL4.4. We have verified the same. The bug can be
closed.

Note You need to log in before you can comment on or make changes to this bug.