Bug 182495 - Desktop icons do not maintain position between logins
Desktop icons do not maintain position between logins
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 183939 186836 187446 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-02-22 16:35 EST by James Laska
Modified: 2013-09-02 02:08 EDT (History)
10 users (show)

See Also:
Fixed In Version: 2.14.1-1.fc5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 23:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Before Login (1.67 MB, image/png)
2006-02-22 16:35 EST, James Laska
no flags Details
After re-login (icons not aligned) (1.64 MB, image/png)
2006-02-22 16:36 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2006-02-22 16:35:02 EST
Description of problem:

The desktop icons are all over the place after logging back into my desktop. 
Prior to logging out they were properly aligned and snapped to grid.

Version-Release number of selected component (if applicable):
nautilus-2.13.91-1.i386

How reproducible: Every time


Steps to Reproduce:
1. Login to desktop
2. Create more than the typical stock icons (I have 4 folders and 4 network shares)
3. Logout and select "Save session"
4. Log back into desktop
  
Actual results:
Icons are not aligned nor are they in the position I left them

Expected results:
Icons should be in the same position as when I logged out

Additional info: See screenshot attachments
Comment 1 James Laska 2006-02-22 16:35:04 EST
Created attachment 125061 [details]
Before Login
Comment 2 James Laska 2006-02-22 16:36:04 EST
Created attachment 125062 [details]
After re-login (icons not aligned)
Comment 3 Stewart Adam 2006-03-06 19:15:59 EST
Hello,
     This is odd... I am seeing the same results except I'm using Fedora Core 5
Test 3.
(Please change dist. field: it's still occuring.)

     It's very annoying, as my regular icons are OK. It's just the network and
media (CD-ROMs and my USB external HD w/ 4 partitions) that will move WAY
up/down, (The whole screen) or occasinally if I'm lucky they won't move at all
but rather swap positions with eachother.

     I've also tried removing the Nautilus metadata files, so it regenerates the
XML files that define their positition, but still a no-go.

Firewing1
Comment 4 Stewart Adam 2006-03-07 18:51:57 EST
OK, I just realized you meant to click FC5T3 and not FC3T3 -- That nautilus
version and your screenshot (new fedora logo) gives it away..
Anyways, I've also noticed that when you hide a panel, the icons move
accordingly. Could this be the problem as I'm using 2 panels?
Firewing1
Comment 5 James Laska 2006-03-08 07:28:48 EST
compustew: oops, you are right, clicked the wrong version when filing.
Comment 6 Stewart Adam 2006-03-14 19:34:01 EST
Hey,
sorry to annoy again but devel is over -- The current release if Fedora Core 5
Test 3...
I just updated to Gnome 2.14, and the same occurs but worse. The icons go ALL
over the place now, not just rearrange themselves.
Firewing1
Comment 7 Bart Vanbrabant 2006-03-15 06:49:48 EST
I havet his problem to. I've uploaded two screenshots. The first one is before I
log out, I've placed all icons like I like them:
http://files.zoeloelip.be/ok.png

After I logout and login again I have this state:
http://files.zoeloelip.be/not_ok.png

(Only the Home dir icon moves, the other documents I removed)
Comment 8 Stewart Adam 2006-03-15 16:29:38 EST
Yes -- For me all icons are OK (meaning they won't change positions) except the
network / removable storage ones, which are completely off the grid. They
usually move from the very top right of my desktop, where I place them, to the
bottom right or even the left.
Firewing1
Comment 9 Alexander Larsson 2006-03-16 05:06:57 EST
*** Bug 183939 has been marked as a duplicate of this bug. ***
Comment 10 Alexander Larsson 2006-03-27 03:24:18 EST
*** Bug 186836 has been marked as a duplicate of this bug. ***
Comment 11 Nikos Charonitakis 2006-03-27 15:47:58 EST
i have a problem like this. Icons get rearranged after first login and home
folder moves down under the trash icon. I manually place home folder to its
proper position but after next login insists to move down again.
Comment 12 Filip Tsachev 2006-03-28 03:43:43 EST
My home icon moves around... FC Bordeaux
Comment 13 Jonathan Haas 2006-03-30 13:00:23 EST
Same here

[XXX@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.16-1.2080_FC5 #1 Tue Mar 28 03:38:34 EST 2006
i686 i686 i386 GNU/Linux
[XXX@localhost ~]$ nautilus --version
Gnome nautilus 2.14.0

Workaround: Remove default home icon (for example with TweakUI) and manually add
an new launcher for your home-dir.
Comment 14 Ignacio Vazquez-Abrams 2006-03-30 18:37:26 EST
*** Bug 187446 has been marked as a duplicate of this bug. ***
Comment 15 Dennis Jacobfeuerborn 2006-04-05 10:41:41 EDT
Where are the icon positions stored?
Comment 16 Stewart Adam 2006-04-05 19:52:24 EDT
~/.metacity/metafiles
Firewing1
Comment 17 Dennis Jacobfeuerborn 2006-04-05 22:03:58 EDT
~/.metacity/metafiles doesn't exist on my machine.
Comment 18 Bela Glosz 2006-04-10 13:52:41 EDT
The same problem here but I made some experiments and finally solved this
annoying thing temporarily. When I made larger space between the icons in
question the middle one just stopped moving after new logins.
Comment 19 petrosyan 2006-04-12 17:33:44 EDT
this bug has been fixed in nautilus-2.14.1, please release that version of
nautilus as an update to Fedora Core 5
Comment 20 petrosyan 2006-04-18 10:35:26 EDT
nautilus-2.14.1-1.fc5.1 from updates-testing fixes this bug
Comment 21 Ben Lentz 2006-09-07 10:35:17 EDT
I wish I had read that (re: nautilus-2.14.1-1.fc5.1) before I got frustrated and
just set .nautilus/metafiles/x-nautilus-desktop:%2F%2F%2F.xml immutable. ;-)

sudo chattr +i .nautilus/metafiles/x-nautilus-desktop\:%2F%2F%2F.xml

Note You need to log in before you can comment on or make changes to this bug.