Bug 182554 - RHGB uses wrong font with no cyrllic support
RHGB uses wrong font with no cyrllic support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 03:58 EST by Alexander Shopov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 12:55:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Large overview of wrong cyrillic. (103.46 KB, image/jpeg)
2006-02-23 04:01 EST, Alexander Shopov
no flags Details
Closeup view of the wrong cyrillic during bootup (129.38 KB, image/jpeg)
2006-02-23 04:01 EST, Alexander Shopov
no flags Details

  None (edit)
Description Alexander Shopov 2006-02-23 03:58:41 EST
Description of problem: When booting Fedora Core 5 Test 3 using a Bulgarian
system locale - the font that rhgb uses during startup contains no cyrillic
letters - so the translated strtings of startup scripts - show squares instead
of cyrillic glyphs.


Version-Release number of selected component (if applicable): RHGB suppled with
fedora core at least after Fedora Core 5 test 2. I have just tested it with the
rhgb-0.16.2-21.2.1.i386.rpm


How reproducible: Every boot when rhgb is used. If not used - the standard text
bootup uses fonts with cyrillic support.


Steps to Reproduce:
1. Boot the machine under a Bulgarian system locale using rhgb

  
Actual results: I will attach 2 pictures with the wron result


Expected results: Bootup using the cyrillic letters
Comment 1 Alexander Shopov 2006-02-23 04:01:04 EST
Created attachment 125089 [details]
Large overview of wrong cyrillic.
Comment 2 Alexander Shopov 2006-02-23 04:01:59 EST
Created attachment 125090 [details]
Closeup view of the wrong cyrillic during bootup
Comment 3 Ray Strode [halfline] 2006-02-23 11:43:21 EST
after you log in, do your cyrillic characters show up okay?
Comment 4 Alexander Shopov 2006-02-23 12:14:59 EST
Even before I log in - the GDM display manager shows Bulgarian ok. I can use
cyrillic in X Window all right.

If you mean the console:
1. Yes - it shows cyrillic letters all right.
2. When I boot without the rhgb option passed to the kernel - the console during
bootup shows cyrillic all right.


More info:
rpm -qa | grep -i font gives:

urw-fonts-2.3-6.1
xorg-x11-fonts-75dpi-7.0-1
xorg-x11-fonts-100dpi-7.0-1
libXfont-1.0.0-2.2
bitstream-vera-fonts-1.10-5.1
xorg-x11-fonts-ISO8859-1-100dpi-7.0-1
fonts-ISO8859-2-75dpi-1.0-16.1
libfontenc-1.0.1-1.2
libXfontcache-1.0.1-1.2
fontconfig-2.3.93.cvs20060211-1
ghostscript-fonts-5.50-13.1
bitmap-fonts-0.3-5.1
fonts-ISO8859-2-100dpi-1.0-16.1
fontconfig-devel-2.3.93.cvs20060211-1
xorg-x11-font-utils-1.0.1-3
xorg-x11-fonts-ISO8859-1-75dpi-7.0-1
chkfontpath-1.10.1-1
xorg-x11-fonts-base-7.0-1
fonts-ISO8859-2-1.0-16.1


cat /etc/sysconfig/i18n  gives

LANG="bg_BG.UTF-8"
SYSFONT="latarcyrheb-sun16"


Comment 5 Alexander Shopov 2006-02-24 02:49:09 EST
Hi, I did some further research and here goes the info, I hope it can be of some
 help

1. In the src.rpm file there is a patch called rhgb-modularx.patch - this is Pat
ch5. Take a look at line number 9:
+#define X_CONFIG "/etc/rhgb/xorg .conf" - Should there be a whitespace between 
xorg and .conf? I think not.

2. About the source of rhgb itself - I think that the font of the vte widget is 
set in src/splash.c - the lines that read:
vte_terminal_set_font_from_string (VTE_TERMINAL (splash->details_terminal), "mon
ospace 12");

Now - I think that the only fonts available to rhgb are those in /usr/share/X11/
fonts/misc (that is from src/main.c)

I uninstalled all fonts available on my system and left only those in /usr/share
/X11/fonts/misc

rpm -e urw-fonts-2.3-6.1 xorg-x11-fonts-75dpi-7.0-1 xorg-x11-fonts-100dpi-7.0-1 
bitstream-vera-fonts-1.10-5.1 xorg-x11-fonts-ISO8859-1-100dpi-7.0-1  fonts-ISO88
59-2-75dpi-1.0-16.1 bitmap-fonts-0.3-5.1  fonts-ISO8859-2-100dpi-1.0-16.1 xorg-x
11-fonts-ISO8859-1-75dpi-7.0-1  ghostscript-fonts-5.50-13.1 fonts-ISO8859-2-1.0-
16.1  --nodeps

All I was left was:
rpm -qa | grep -i font

bXfont-1.0.0-2.2
libfontenc-1.0.1-1.2
libXfontcache-1.0.1-1.2
fontconfig-2.3.93.cvs20060211-1
fontconfig-devel-2.3.93.cvs20060211-1
xorg-x11-font-utils-1.0.1-3
chkfontpath-1.10.1-1
xorg-x11-fonts-base-7.0-1
Then I exited X, went in again, rebuild the fontcache:

fc-cache -fsv

and did

fc-match -v "monospace 12"

I received no resutls then.

After that I did:

xlsfonts | grep -i monospace

And once again - no results.

I tried displaying cyrillic letters in xterm - they did not show. Firefox also d
id not start - and it uses Bulgarian in the interface - so there was something w
rong with finding cyrillic letters.

Then I tried starting xterm with different options to get a font containing cyri
llic:

But I always got a segmentation fault:

[ash@kochinka ~]$ xterm -fa -*-*-*-*-*-*-*-*-*-*-*-*-iso10646-1
Segmentation fault
[ash@kochinka ~]$ xterm -fa -*-*-*-*-*-*-*-*-*-*-*-*-koi8-r
Segmentation fault
[ash@kochinka ~]$ xterm -fa -*-*-*-*-*-*-*-*-*-*-*-*-iso8859-5
Segmentation fault

I could find fonts containing cyrillic letters with xfontsel, but I could not us
e them in xterm because of the segmentation faults.


Comment 6 Alexander Shopov 2006-02-28 01:12:01 EST
Further info - after the latest update  I am still unable to see any cyrillic
letters in RHGB vte widget.
I even tried putting the DejaVu TTF fonts in /usr/share/X11/fonts/misc/


cd /usr/share/X11/fonts/misc/
ls *ttf gives:
-rw-r--r-- 1 root root 128312 27 фев 17,13 DejaVuSansMono-BoldOblique.ttf
-rw-r--r-- 1 root root 118756 27 фев 17,13 DejaVuSansMono-Bold.ttf
-rw-r--r-- 1 root root 134748 27 фев 17,13 DejaVuSansMono-Oblique.ttf
-rw-r--r-- 1 root root 126412 27 фев 17,13 DejaVuSansMono.ttf

but still no cyrillic.
Comment 7 Alexander Shopov 2006-02-28 06:55:08 EST
Hi,
Today there have been numerous updates - vte, fonts etc. Some update has fixed
the problem - I get cyrillic letters in the vte widget of rhgb during bootup.
You may close this bug. I do not know which one fixed it.
Comment 8 Ray Strode [halfline] 2006-02-28 12:55:48 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.