Bug 182560 - Wrong retval for initscript when smbd is dead
Summary: Wrong retval for initscript when smbd is dead
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 196210 (view as bug list)
Depends On:
Blocks: 181409
TreeView+ depends on / blocked
 
Reported: 2006-02-23 11:03 UTC by Bastien Nocera
Modified: 2014-08-31 23:28 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0599
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:43:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
samba-fix-initscript-retval.patch (242 bytes, patch)
2006-02-23 11:03 UTC, Bastien Nocera
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0599 normal SHIPPED_LIVE samba bug fix update 2006-08-10 04:00:00 UTC

Description Bastien Nocera 2006-02-23 11:03:56 UTC
samba-3.0.10-1.4E.3

$ service smb start
Starting SMB services:                                     [  OK  ]
Starting NMB services:                                     [  OK  ]
$ service smb status && echo working
smbd (pid 20402 20401) is running...
nmbd (pid 20406) is running...
working
$ killall smbd
$ service smb status && echo working
smbd dead but pid file exists
nmbd (pid 20406) is running...
working

Patch attached.

Comment 1 Bastien Nocera 2006-02-23 11:03:56 UTC
Created attachment 125094 [details]
samba-fix-initscript-retval.patch

Comment 5 Bob Johnson 2006-04-11 16:09:05 UTC
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.

Comment 12 Jay Fenlason 2006-06-30 20:49:30 UTC
*** Bug 196210 has been marked as a duplicate of this bug. ***

Comment 13 Red Hat Bugzilla 2006-08-10 21:43:26 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0599.html



Note You need to log in before you can comment on or make changes to this bug.