Bug 182571 - WPA-PSK CCMP keychange do not work with wpa_supplicant script
WPA-PSK CCMP keychange do not work with wpa_supplicant script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 08:36 EST by Uwe Beck
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 22:01:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
wpa_supplicant.sysconfig (461 bytes, text/plain)
2006-02-28 10:31 EST, Uwe Beck
no flags Details
wpa_supplicant.init.d (1.66 KB, text/plain)
2006-02-28 10:34 EST, Uwe Beck
no flags Details
wpa_supplicant.spec (5.49 KB, text/plain)
2006-02-28 10:36 EST, Uwe Beck
no flags Details

  None (edit)
Description Uwe Beck 2006-02-23 08:36:37 EST
Description of problem:
I have configure wpa_supplicant to connect to an accesspoint with
WPA-PSK and CCMP (WPA-PSK and AES on accesspoint config).

If I start wpa_supplicant the connection is active after some time.
This connection goes down if it is time for the keychange. You can
only start wpa_supplicant new anh hope, that the connection comes up.

Debugging this: start wpa_supplicant on commandline

# wpa_supplicant -Dmadwifi  -iath0 -c /etc/wpa_supplicant/wpa_supplicant.conf -d
With this command the keychange does not work.
# wpa_supplicant -w -Dmadwifi  -iath0 -c /etc/wpa_supplicant/wpa_supplicant.conf -d
Now the keychange work correct.

I take the -w option in the /etc/rc.d/init.d/wpa_supplicant script. The
connection established and is activ. But if it time for the keychange the
connection goes down.
The script use "daemon wpa_supplicant -B ...".
There is no logfile and so there is no posibility for debugging.

Also: missing wpa_passphrase binary in RPM. You need it for generate the WPA-PSK
key for wpa_supplicant.conf.

Version-Release number of selected component (if applicable):
wpa_supplicant-0.5.1-3

How reproducible:
every time

Steps to Reproduce:
1. configure wpa_supplicant with WPA-PSK and CCMP
2. service wpa_supplicant start
3. wait for keychange (time is configure at accesspoint)
4. see the end of connection
  
Actual results:
only work from commandline without -B and with -w options

Expected results:
should work as service

Additional info:
wpa_passphrase binary in RPM
Comment 1 Uwe Beck 2006-02-28 10:31:54 EST
Created attachment 125399 [details]
wpa_supplicant.sysconfig

better wpa_supplicant for /etc/sysconfig
Comment 2 Uwe Beck 2006-02-28 10:34:20 EST
Created attachment 125401 [details]
wpa_supplicant.init.d

initscript for new wpa_supplicant.sysconfig
Comment 3 Uwe Beck 2006-02-28 10:36:19 EST
Created attachment 125402 [details]
wpa_supplicant.spec

- new spec file
- add /usr/sbin/wpa_passphrase
- add OPTIONS and MULTIPLE in /etc/sysconfig/wpa_supplicant
- add OPTIONS and MULTIPLE in /etc/rc.d/init.d/wpa_supplicant
- set OPTIONS="-B -w"
Comment 4 Dominik 'Rathann' Mierzejewski 2006-04-07 11:01:08 EDT
What is the use of MULTIPLE? Can you give an example where another variable is
required and OPTIONS and INTERFACES cannot be used?
Comment 5 Uwe Beck 2006-05-07 08:10:13 EDT
In /etc/rc.d/init.d/wpa_supplicant there is only set -B for start the
wpa_supplicant daemon. -w is very helpfull for me (look at manual what -w means)
but there is no way to set it in the system. OPTIONS allow it.

If you have more than on card in the system and that are also different cards
then you can use -N (look at manual and README) to use them. I do this with
help of variable MULTIPLE.

Is there a better solution available during boot the system?
Comment 6 Uwe Beck 2006-05-07 08:15:43 EDT
I was allso going back to wpa_supplicant-0.4.8 like FC5 since Comment#2.
Comment 7 Matthew Miller 2007-04-06 13:42:47 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 8 Uwe Beck 2007-04-06 17:23:47 EDT
There was no problem since wpa_supplicant-0.4.8-10.1.fc6 for me, if I use my
changes in /etc/sysconfig/wpa_supplicant and /etc/rc.d/init.d/wpa_supplicant.

I use this rpm version also in RHEL4. RHEL5 has also this rpm version. The
RHEL4.5 beta channel contains wpa_supplicant-0.4.9-1.1.el4. All this versions
work for me without the problem that was reported in this issue.

If an OPTIONS variable would be in /etc/sysconfig/wpa_supplicant and
/etc/rc.d/init.d/wpa_supplicant the rpm would be more flexible for all users. If
the daemon works for you without options you don't set any options in
/etc/sysconfig/wpa_supplicant. All other users can do it if they need options.

At this time Red Hat do not allow this and updates will overwrite your own
/etc/rc.d/init.d/wpa_supplicant script.

There are some issues in Red Hat's issue tracker for RHEL4.5 beta and RHEL5 from me.
Comment 9 Matthew Miller 2007-04-06 22:01:06 EDT
Ah, I see they backed the version out before FC5 release. So this is fixed as of
FC5 final...

Note You need to log in before you can comment on or make changes to this bug.