Bug 182574 - sk98lin fails to loading Marvell 88E1111 & 88E8053 on Athlon64x2
sk98lin fails to loading Marvell 88E1111 & 88E8053 on Athlon64x2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
NeedsRetesting
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 09:04 EST by Hamed Saber
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.18-1.2200.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 13:24:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hamed Saber 2006-02-23 09:04:21 EST
Description of problem:
I have an Athlon64x2 on MSI K8N Neo4 Platinum which has two onboard ethernet
devices (Marvell 88E1111 & 88E8053).
The FC4-x84_64 could not detect the eths, so I downloaded the latest version of
drivers from syskonnect.com (version b8.31.2.3, 18.01.2006) and followed its
instructions. All the installation process was successfull, but at next restart,
when I tried to call "modprobe sk98lin" I recieved this message:

sk98lin: no version for "struct_module" found: kernel tainted.

Version-Release number of selected component (if applicable):
Linux 2.6.11-1.1369_FC4smp

How reproducible:
Everytime

Steps to Reproduce:
1. Try to install the driver
2. Try to modprobe it
  
Actual results:
Just an error in STDOUT, no data in /var/log/messages

Expected results:
It should find and install eth0 and eth1 at /proc/net/sk98lin/ etc.


Additional info:
I did also try elder versions of the driver, some of them failed on compile
time, and the others didn't work as expected.
Comment 1 Hamed Saber 2006-02-23 15:09:59 EST
I tried netdev package, and it got worked.
Comment 2 Dave Jones 2006-09-16 23:01:04 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 3 Dave Jones 2006-10-16 15:16:46 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Jarod Wilson 2006-11-01 13:24:47 EST
Those NICs should be perfectly functional with the sky2 driver now. sk98lin is
dead and gone from the kernel. Please open a new bug if they are still
non-functional with the sky2 driver.

Note You need to log in before you can comment on or make changes to this bug.