Bug 18258 - Windows '95 '-r' nmblookup fix fails to return.
Windows '95 '-r' nmblookup fix fails to return.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 16:06 EDT by Ian Norton
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 15:11:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Norton 2000-10-03 16:06:36 EDT
When running nmblookup with the -r flag, it fails to return.  Worked on on 7 beta but seems to be failing in 7.

[root@radio /root]# nmblookup -A 148.88.17.123 -r
Looking up status of 148.88.17.123
No status response (this is not unusual)

Hope this hasn't been reported already.

Thanks.
Comment 1 giulioo 2000-10-04 06:08:38 EDT
More than "fail to return" I'd say that "returns no output".
Have you tried without -r?

This -r was added for compatibility with old win95s, but if you updated part of 
the network stack then it may work as win98 does.

I have a win95 box, without -r it works, with -r it returns no output like you 
reported (like it happens if you use -r with win98).
Comment 2 giulioo 2000-10-04 08:30:27 EDT
Sorry, I was wrong.
I think this is not well documented, but if you want to use "-r" you have to 
shut down samba, or at list nmbd, because -r wants to use the same port nmbd is 
using.

Can you try "-r" with nmbd stopped?

== 
[root@b samba]# /etc/rc.d/init.d/smb start
Starting SMB services:                                     [  OK  ]
Starting NMB services:                                     [  OK  ]
[root@b samba]# nmblookup -A x.0.0.172
Looking up status of x.0.0.172
received 5 names
        GO              <00> -         M <ACTIVE>
        WORKGROUP       <00> - <GROUP> M <ACTIVE>
        GO              <03> -         M <ACTIVE>
        GO              <20> -         M <ACTIVE>
        WORKGROUP       <1e> - <GROUP> M <ACTIVE>
num_good_sends=0 num_good_receives=0
 
[root@b samba]# nmblookup -A x.0.0.172 -r
Looking up status of x.0.0.172
No status response (this is not unusual)
 
[root@b samba]# killall nmbd
[root@b samba]# nmblookup -A x.0.0.172 -r
Looking up status of x.0.0.172
received 5 names
        GO              <00> -         M <ACTIVE>
        WORKGROUP       <00> - <GROUP> M <ACTIVE>
        GO              <03> -         M <ACTIVE>
        GO              <20> -         M <ACTIVE>
        WORKGROUP       <1e> - <GROUP> M <ACTIVE>
num_good_sends=0 num_good_receives=0
 
[root@b samba]#
==

So yes, if you have an old win95 (not updated) that does not answer without "-
r" you have to shut down nmbd.

Comment 3 Ian Norton 2000-10-04 09:14:19 EDT
Under Redhat 6.2 and 7 beta, the -r works for 95, 98, NT, 2000 and linux all whilst samba (both smbd and nmbd) is running.
I know this is the case as network management software we developed and are using uses this flag with no problem (The box it runs on is a 7beta).

The -r flag doesn't seem to work to a test 95 box under 7 regardless of the status of smbd/nmbd.
Comment 4 Ian Norton 2000-10-04 09:17:33 EDT
Ok :-)  The -r doesn't work whilst nmb/smb is running, but we're not running either on the server we're trying this from.
Comment 5 Henri Schlereth 2001-01-21 10:39:57 EST
This from a machine that is running a samba server to a win95a box.

nmblookup 192.168.1.3
querying 192.168.1.3 on 192.168.1.255
querying 192.168.1.3 on 127.255.255.255
name_query failed to find name 192.168.1.3

nmblookup -A 192.168.1.3 -r
Looking up status of 192.168.1.3
No status response (this is not unusual)

nmblookup -A 192.168.1.3
Looking up status of 192.168.1.3
No status response (this is not unusual

nmblookup anna
querying anna on 192.168.1.255
192.168.1.3 anna<00>

nmblookup -A anna
Looking up status of 192.168.1.3
No status response (this is not unusual)

nmblookup -A anna -r
Looking up status of 192.168.1.3
No status response (this is not unusual)
Comment 6 Trond Eivind Glomsrxd 2001-06-21 19:35:42 EDT
It works fine here, except you get get an empty response when using "-r" if
samba is already running (which is understable, as this port is used).

Note You need to log in before you can comment on or make changes to this bug.