Bug 182583 - An unhandeld exception has occured while re-installing FC3 to fix booting problems caused by installing SUSE10 on the system (but on another device)
An unhandeld exception has occured while re-installing FC3 to fix booting pro...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 09:57 EST by Khalid El-Gazzar
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 11:56:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Khalid El-Gazzar 2006-02-23 09:57:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-16

Description of problem:
I had Fedora Core 3 installion on my laptop (on /dev/hda8) then I decided to install SUSE10 on another partion (/dev/hda6). The problem I have now is that FC3 is not booting any more, I tried to use the FC3 installion CDs to in the rescue mode but it gave error. I decided that I will to select upgrade the existing system while installing from the FC3 CDs. I got the following error.

I'd be glad if anyone can help, since I already have installed many packages on FC3 and will b painful to reinstall stuff again. One other note, When booting SUSE, I can mount /dev/hda8 and access my files and stuf there. The FC3 partition (/dev/hda8) is formatted as ext3, while the SUSE10 partion (/dev/hda6) is formatted as reiser.


==================(  Start of Error message )================================
An unhandeld exception has occured. This is most likely a bug.
Please copy the full text of this exception and file a detialed bug 
report against anaconda at http://bugzilla.redhat.com/bugzilla/

--------------------( Start of white board )----------------------------
Traceback (most recent call last):
File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py", line 789, in nexClicked
self.dispatch.gotoNext()

File "/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line 171, in gotoNext
self.moveStep()

File "/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line 239, in moveStep
rc = apply(func,self.bindArgs(args))

File "/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line 264, in upgradeMountFilesystems
allowDirty = 0)

File "/usr/src/build/475969-i386/install//usr/lib/anaconda/upgrade.py", line 141, in mountRootPartition
oldfsset.mountFileSystems(instPath,readOnly = readOnly)

File "/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py", line 1568, in makeLVMNodes
if isinstance(root.device,LogicalVolumeDevice) or rootlvm1:
AttributeError: 'NoneType' object has no attribute 'device'
---------------------(  End  of white board )-----------------------------
=================(  End  of Error message )============================

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Jeremy Katz 2006-02-24 11:56:50 EST
Fedora Core 3 is no longer supported for new installations.  This issue has been
resolved in newer releases

Note You need to log in before you can comment on or make changes to this bug.