Bug 182607 - RFE: rpmbuild should warn for unused shared libraries
RFE: rpmbuild should warn for unused shared libraries
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 12:22 EST by dann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-18 08:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script to run ldd -u -r against executables and libraries (782 bytes, text/plain)
2006-03-18 08:46 EST, Jeff Johnson
no flags Details

  None (edit)
Description dann 2006-02-23 12:22:53 EST
According to Ulrich Drepper's "How to write shared libraries" document
(http://people.redhat.com/drepper/dsohowto.pdf document)
unused shared libraries are to be avoided because they impose unwanted overheads.  

A huge number of shared libraries in FC have unused dependencies.
As part of sanity checking the package 
rpmbuild could run "ldd -u -r " on all binaries and shared libraries and warn
about unused libraries. This could make package authors aware of the issue and
provide an incentive to improve the package.

Just my 2 cents.
Comment 1 Jeff Johnson 2006-03-18 08:33:48 EST
The idea is sound, and rpm could pretty easily add a build root policy check like
the attached script if desired.

However, the choice to eliminate unused shared libraries is way outside the scope of rpm
even though a rpmbuild build root policy script might very well be an efficient implementation
mechanism.
Comment 2 Jeff Johnson 2006-03-18 08:44:15 EST
The idea is sound, and rpm could pretty easily add a build root policy check like
the attached script if desired.

However, the choice to eliminate unused shared libraries is way outside the scope of rpm
even though a rpmbuild build root policy script might very well be an efficient implementation
mechanism.
Comment 3 Jeff Johnson 2006-03-18 08:46:49 EST
Created attachment 126302 [details]
script to run ldd -u -r against executables and libraries

Try
    find /bin | ldd-unused.sh

Note You need to log in before you can comment on or make changes to this bug.