Bug 18268 - LABEL: in fstab is dangerous
LABEL: in fstab is dangerous
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 18:05 EDT by Mark B. Allan
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 09:03:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark B. Allan 2000-10-03 18:05:35 EDT
Using LABEL: in fstab instead of a /dev/hd* entry is a very bad idea
because many people (myself included) have several Linux installs on the
same machine. When I do an upgrade, I keep the old version and install the
new version on different partitions (keeping only /home and /usr/local) so
I can go back to the old OS if necessary. What happens when there are two
or three partitions with the label "/usr"?
Comment 1 Erik Troan 2000-10-05 09:03:43 EDT
The install checks all type 0x83 partitions for labels to make sure that it is
using unique labels. If a / already exists, for example, the new / will be
label'd /1. Similiar changes happen for /usr, and to avoid
/usr/share/something/or/other and /usr/share/something/or/this from having
the same label after being truncated to fit in the superblock. Yes, this has all
been tested ;-)

Note You need to log in before you can comment on or make changes to this bug.