Bug 182697 - eject does not eject anything
Summary: eject does not eject anything
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eject   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-24 02:46 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-23 20:03:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2006-02-24 02:46:03 UTC
Description of problem:

After CD got mounted one can try to use 'eject' (as various scripts, for
example, were doing for years).  For mysterious reasons, as it has a volume
label, CD this time got mounted on /media/disk (????).  Whatever.  After
typing 'eject' we see:

umount: /media/disk is not in the fstab (and you are not root)
eject: unmount of `/media/disk' failed

One would think that 'eject' at least could try to use 'gnome-mount -e'
at this point as that one seems to be able to do the job at least when
called with '-d <device>' for arguments.

OK, so lets try as root.  A CD got mounted this time, mysteriously,
on "/media/FC_5-Test3 i386".

# eject
umount: /media/FC_5-Test3\040i386: not found
eject: unmount of `/media/FC_5-Test3\040i386' failed

so beeing root is not good enough either.

Actually it looks like that eject should work through 'gnome-mount',
if available, as the later expects that old mount points in /media
are getting removed.

(No, I am far from pleased with what Gnome is doing here.)

Version-Release number of selected component (if applicable):
eject-2.1.2-1.2.1

How reproducible:
always

Comment 1 Ngo Than 2006-08-23 20:03:43 UTC
it should be fixed in recent eject-2.1.5-0.1.fc5 from FC5-update. Thanks for 
your report


Note You need to log in before you can comment on or make changes to this bug.