Bug 182724 - log_file commands creates log file with executable permissions
log_file commands creates log file with executable permissions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: expect (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 05:25 EST by Thomas Mellman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 13:18:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Mellman 2006-02-24 05:25:30 EST
Description of problem:

log_file command creates a log file with executable permissions

Version-Release number of selected component (if applicable):

expect version 5.39.0

How reproducible:

log_file spider.cons

Steps to Reproduce:
1.run that
2.
3.
  
Actual results:

-rwxr-xr-x  1 mellman mellman 8365 Feb 24  2006 spider.cons

Expected results:

-rw-r--r--  1 mellman mellman 8365 Feb 24  2006 spider.cons

Additional info:

Is this a relic of the windows port?
Comment 1 David Cantrell 2006-02-24 09:51:05 EST
FC1 is no longer supported directly by the Fedora Project.  The Fedora Legacy
project continues support for older releases.

I have checked rawhide (expect version 5.43.0) and the behavior is the same, so
it looks like this bug has always been present.  I'm sure it's just a umask
issue with creating files.

Development is currently frozen for FC5 final as we are working on critical bugs
at the moment.  If I can get a fix in for this before FC5 final, I will,
otherwise it'll go in to rawhide after FC5 is released.
Comment 2 David Cantrell 2006-03-01 14:30:05 EST
I have a fix for this problem.  It will be in rawhide after FC5 is final.  It's
too late for me to work that in now.

Thanks.
Comment 3 David Cantrell 2006-03-22 13:18:38 EST
Fixed in rawhide.  New package will be expect-5.43.0-4.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.