Bug 182730 - Exception in upgrade FC4 to FC5 test 3
Exception in upgrade FC4 to FC5 test 3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 208600 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 06:09 EST by Simon Handy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 17:03:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception dump (128.67 KB, text/plain)
2006-03-05 10:34 EST, Simon Handy
no flags Details
Installer log. (13.05 KB, text/plain)
2006-03-05 10:39 EST, Simon Handy
no flags Details

  None (edit)
Description Simon Handy 2006-02-24 06:09:09 EST
Description of problem:
Using DVD version of FC5 test 3 to update FC4 install on Acer Aspire 3003.
Sempron 1.6Ghz 256MB, 30G space left on FC4 root partition.

Upon clicking next after selecting "Upgrade Existing Installation", anaconda 
thinks for a few seconds and then produces window saying exception has occurred.

Looking at bug details, it seems anaconda has done all of the selecting for 
which packages to upgrade but not got to upgrading any of them yet.  The only 
error I can see in the traceback is in FSSET.PY which says there is 
an "UnboundLocalError" and "errnum" not found.

I have tested the media with both the SHA1SUM and the media test at the 
beginning of the install, neither test comes back with any problems.

Version-Release number of selected component (if applicable):
Not component specific.

How reproducible:
Every time I try.

Steps to Reproduce:
1. Insert DVD FC5 Test 3 media and boot
2. Select graphical install, English language, UK Keyboard
3. Select upgrade existing installation, press next.
  
Actual results:
Window appears with exception occurred.  Installation cannot continue.
Have option to debug but I have no experience with debugging.

Expected results:
Installation should continue and upgrade FC4 to FC5

Additional info:
None
Comment 1 Jeremy Katz 2006-02-24 11:43:30 EST
Can you provide teh complete traceback you received?
Comment 2 Simon Handy 2006-03-05 10:34:16 EST
Created attachment 125669 [details]
Exception dump
Comment 3 Simon Handy 2006-03-05 10:39:12 EST
Created attachment 125670 [details]
Installer log.
Comment 4 Simon Handy 2006-03-05 10:40:39 EST
Sorry it took so long.  Wasn't aware of where the install output was going. :-)
Comment 5 Chris Lumens 2006-03-06 10:45:32 EST
Could you attach the /etc/fstab file from the system you're trying to install? 
Looks like we're trying to mount an NTFS filesystem for some reason.
Comment 6 Simon Handy 2006-03-06 12:44:28 EST
Sorry, yes, I do mount an NTFS partition.  Will remove this line from fstab for
the upgrade.
Thanks.
Comment 7 Chris Lumens 2006-03-10 17:03:24 EST
The problem here is that we're assuming we can mount any filesystem of type
auto, which of course we can't do in this case.  But we can at least raise a
more useful exception.
Comment 8 Chris Lumens 2006-10-02 11:14:45 EDT
*** Bug 208600 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.