Bug 182736 - nc doesn't timeout
nc doesn't timeout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
: 199503 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 07:50 EST by Ward Wouts
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.84-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 11:33:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ward Wouts 2006-02-24 07:50:17 EST
Description of problem:
nc doesn't timeout, while using -w option

Version-Release number of selected component (if applicable):
nc-1.82-fc4.1

How reproducible:
always

Steps to Reproduce:
1. nc -w 1 <unreachable host> <port>
2.
3.
  
Actual results:
nc doesn't timeout


Expected results:
nc should timeout in 1 second

Additional info:
Comment 1 Radek Vokal 2006-03-06 11:33:28 EST
Fixed in nc-1.84-4. The -w option will work also for connection. 
Comment 2 Radek Vokal 2006-07-20 03:06:15 EDT
*** Bug 199503 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.