Bug 182748 - SELinux prevents dbus from starting
SELinux prevents dbus from starting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
: 182747 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 09:27 EST by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 11:20:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grep dbus /var/log/audit/audit.log (3.16 KB, text/plain)
2006-02-24 11:07 EST, David Nielsen
no flags Details
full audit.log (4.63 MB, text/plain)
2006-02-24 11:44 EST, David Nielsen
no flags Details

  None (edit)
Description David Nielsen 2006-02-24 09:27:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060212 Epiphany/1.9

Description of problem:
DBUS fails to come up during boot and networkmanager tells me the following:

Feb 24 15:17:07 price NetworkManager: <WARNING>  nm_dbus_get_networks_cb (): nm-dbus-nmi.c:527 (nm_dbus_get_networks_cb): error received: org.freedesktop.DBus.Error.AccessDenied - An SELinux policy prevents this sender from sending this message to this recipient (rejected message had interface "org.freedesktop.NetworkManagerInfo" member "getNetworks" error name "(unset)" destination "org.freedesktop.NetworkManagerInfo").

Version-Release number of selected component (if applicable):
selinux-policy-2.2.20-1

How reproducible:
Always

Steps to Reproduce:
1. Enable dbus and SELinux

  

Actual Results:  2. obtain the cryptic message above 

Expected Results:  2. Running DBUS.

Additional info:

Running Development as of 24-02-06 on Athlon-XP 1600+
Comment 1 David Nielsen 2006-02-24 09:28:53 EST
*** Bug 182747 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2006-02-24 09:40:19 EST
What avc messages are you seeing?
Comment 3 David Nielsen 2006-02-24 09:48:52 EST
I'm not seeing any avc messages for some reason - all I get is the message
above. I tested with and without SELinux and without dbus starts. The filesystem
is relabeled.
Comment 4 Daniel Walsh 2006-02-24 10:43:05 EST
semodule -b /usr/share/selinux/targeted/enableaudit.pp

Will turn on all auditing messages.
semodule -b /usr/share/selinux/targeted/base.pp

Turns them back off.

What version of dbus are you running?

I have not seen this here.  But maybe I am not running the same version.

John, 
Have you seen this?
Comment 5 David Nielsen 2006-02-24 11:06:27 EST
dbus-0.60-7.2

Attached is everything in the audit.log that pretains to dbus.
Comment 6 David Nielsen 2006-02-24 11:07:17 EST
Created attachment 125186 [details]
grep dbus /var/log/audit/audit.log
Comment 7 John (J5) Palmieri 2006-02-24 11:22:05 EST
Works for me.  I have seen issues with NetworkManager but D-Bus starts up fine.
 David can you confirm that D-Bus does not run?  do a 'ps -aux | grep dbus'. 
Also a more complete audit log would be useful.
Comment 8 David Nielsen 2006-02-24 11:37:28 EST
Okay now it's just taunting me, dbus is running, the problem must thus be
elsewhere. Why does the boot sequence then tell me that dbus fails I wonder.

dbus      1778  0.0  0.1  13396  1244 ?        Ssl  17:18   0:00 dbus-daemon
--system
david     2044  0.0  0.0   4052   676 ?        Ss   17:18   0:00
/usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /etc/X11/xinit/Xclients
david     2047  0.0  0.0   2852   516 ?        S    17:18   0:00
/usr/bin/dbus-launch --exit-with-session /etc/X11/xinit/Xclients
david     2048  0.0  0.1  13260  1380 ?        Ssl  17:18   0:00 dbus-daemon
--fork --print-pid 8 --print-address 6 --session
Comment 9 David Nielsen 2006-02-24 11:44:18 EST
Created attachment 125188 [details]
full audit.log
Comment 10 David Nielsen 2006-02-27 10:57:24 EST
after todays update this magically went away

Note You need to log in before you can comment on or make changes to this bug.