This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 18292 - bad #include in /usr/include/db1/ndbm.h
bad #include in /usr/include/db1/ndbm.h
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: db1 (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 00:43 EDT by Ion Badulescu
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 02:57:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ion Badulescu 2000-10-04 00:43:26 EDT
If db1-devel is installed and db3-devel is not installed, including
<db1/ndbm.h> causes a compile error because <db.h> is not found.

If both db1-devel and db3-devel are installed, then there is no
compile error, but there is potential for bizarre run-time errors,
because both packages provide db.h, but the two files are very different.
This is how your shipped am-utils package is compiled, by the way.

The fix is simple: make ndbm.h include <db1/db.h>, not just <db.h>.

RH62 suffers from the same problem, except it never causes compile
errors because <db.h> and <db1/db.h> are part of the same package
(glibc-devel).
Comment 1 Jeff Johnson 2000-10-06 15:29:08 EDT
Fixed in db1-1.85-5. Thanks for reporting.

Note You need to log in before you can comment on or make changes to this bug.