Bug 182933 - Radeon Mobility X700 installation/runtime failure
Radeon Mobility X700 installation/runtime failure
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 10:40 EST by Philippe Rigault
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 12:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (144.12 KB, text/plain)
2006-02-24 14:42 EST, Philippe Rigault
no flags Details
xorg.conf (2.67 KB, text/plain)
2006-02-24 14:43 EST, Philippe Rigault
no flags Details
Configuration working at native resolution on flat panel (2.87 KB, text/plain)
2006-03-08 13:04 EST, Philip Trickett
no flags Details
Xorg.conf file / works with radeon x700. (2.97 KB, application/octet-stream)
2006-03-31 13:07 EST, Kyle Pablo
no flags Details
Photo taken after X has been started. (51.45 KB, image/jpeg)
2006-04-03 15:58 EDT, Jan-Petter Vainionpaa
no flags Details
The xorg.conf file I used to get X working poorly (2.89 KB, application/octet-stream)
2006-04-03 16:04 EDT, Jan-Petter Vainionpaa
no flags Details
I have modified this file from its original content (2.58 KB, text/plain)
2006-04-13 10:28 EDT, Jan-Petter Vainionpaa
no flags Details

  None (edit)
Description Philippe Rigault 2006-02-24 10:40:45 EST
Description of problem: Installation of Fedora Core 5 test3 is not possible on  
Acer Ferrari 4005WLMi. Anaconda hangs in graphical mode, and text mode is   
messed up to a point where the user cannot select items   
      
      
Version-Release number of selected component (if applicable):      
      
      
How reproducible: Always      
      
      
Steps to Reproduce:      
1. Boot FC5test3 on Acer Ferrari 4005WLMi      
2. Type linux or Enter (graphical install) OR linux text (text install)      
    
        
Actual results:    
 Graphical install -> Boot hangs when starting X      
 Text install      -> Messed up menus  
      
Expected results:   
 Graphical install -> X starts, graphical boot proceeds      
 Text install      -> Correct menus   
    
      
Additional info:      
Acer Ferrari 4005WLMi    
AMD Turion 2.0GHz  
ATI Radeon Mobility X700
Comment 1 Jeremy Katz 2006-02-24 11:45:36 EST
Does X work post-install?
Comment 2 Philippe Rigault 2006-02-24 14:42:28 EST
Created attachment 125203 [details]
Xorg.0.log

No, X does not work.
Log file attached.
Comment 3 Philippe Rigault 2006-02-24 14:43:41 EST
Created attachment 125204 [details]
xorg.conf 

xorg.conf file created by anaconda
Comment 4 Philippe Rigault 2006-02-24 15:41:45 EST
Title should be changed to something like: 
Cannot run X on Acer Ferrari 4005WLMi 
 
The text install, although amounting to painful guesswork, did proceed. 
Comment 5 Mike A. Harris 2006-03-04 01:27:10 EST
If you boot with "selinux=0" does that help?
Comment 6 Philippe Rigault 2006-03-04 09:52:39 EST
> If you boot with "selinux=0" does that help? 
  
No  
 - Installing with "linux selinux=0" hangs X the same way  
 - Post-install, I always boot with selinux=0 (option added in grub.conf).  
  
Note: The box is brand new and runs graphics OK with "The other OS". So I do 
not suspect hardware. 
  
  
Comment 7 Philippe Rigault 2006-03-04 10:11:38 EST
Workaround for messed-up menus in text-mode install  
(which is really anaconda bug, not X)  
   
As was mentioned in the mailing lists:   
https://www.redhat.com/archives/fedora-test-list/2006-March/msg00205.html 
    
Installing with "linux text askmethod" results in menus rendered correctly.  
  
This should be fixed in rawhide: 
 https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=182706 
I will test that if I have the time. 
 
In any case, FC5 final should render menus correctly with "linux text". 
It should also gracefully fall back on text install if it cannot install in 
graphics mode.  
  
   
  
   
   
Comment 8 WangKeMeng 2006-03-04 20:58:02 EST
This is because the LCD panel not recognized by installer, connect to external
CTR,all seems  
work fine,but at the startup stage, kudzu crash, and the firstboot hunge kernel.
skip all of those steps, it works fine.
change xorg.conf, add MonitorLayout options for LCD panel.see xorg mail list for
this bug.
My notebook is Ferrari 4002
Comment 9 Philippe Rigault 2006-03-06 10:26:40 EST
Connecting an external monitor indeed gets the graphical install going. 
So it seems the problem is recognizing the 1680x1050 LCD panel. 
Thanks much! 
 
System is installing right now, I will report my post-install findings. 
Comment 10 Jan-Petter Vainionpaa 2006-03-06 12:42:38 EST
I have same problem with my Fujitsu-Siemens Amilo A1667-G20
- ATI Mobility Radeon X700 with 128Mb memory 
- 15.4” TFT LCD WXGA (1280x800) display
- AMD Turion™64 Mobile Technology MT-32

Comment 11 Mike A. Harris 2006-03-06 18:12:28 EST
(In reply to comment #7)
> Workaround for messed-up menus in text-mode install  
> (which is really anaconda bug, not X)  
>    
> As was mentioned in the mailing lists:   
> https://www.redhat.com/archives/fedora-test-list/2006-March/msg00205.html 
>     
> Installing with "linux text askmethod" results in menus rendered correctly.  
>   
> This should be fixed in rawhide: 
>  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=182706 
> I will test that if I have the time. 
>  
> In any case, FC5 final should render menus correctly with "linux text". 
> It should also gracefully fall back on text install if it cannot install in 
> graphics mode.  

Agreed in both cases, however those problems are unrelated to this specific
bug report.  Please file separate bug reports against anaconda for those
problems.
Comment 12 Mike A. Harris 2006-03-06 18:37:05 EST
(In reply to comment #9)
> Connecting an external monitor indeed gets the graphical install going. 
> So it seems the problem is recognizing the 1680x1050 LCD panel. 
> Thanks much! 
>  
> System is installing right now, I will report my post-install findings. 

What were your post-install findings?  ;o)

Also, since this fails with x86_64 for you, have you also tested the i386
32bit install?  It would be useful to know if it happens only on AMD64 or
also x86.

TIA
Comment 13 Philippe Rigault 2006-03-06 19:12:17 EST
>  What were your post-install findings?  ;o)  
Immediately after install  
 - Updated kudzu to 1.2.33-1 (rawhide)  
   kudzu no longer segfaults. 
 - Updated firstboot to 1.4.6-1 (rawhide)  
  
I could start X on the external CRT post install. I am now working on getting 
a xorg.conf that works for the LCD panel alone. 
 
Comment 14 Philippe Rigault 2006-03-06 19:18:46 EST
One more thing, running 
 setup -> X configuration 
hangs the machine. 
 
Comment 15 Philippe Rigault 2006-03-06 19:31:46 EST
> have you also tested the i386 32bit install?   
Since you asked ;-) 
I just did that (FC-5-Test3-i386-disc1.iso)  
 
Same story: 
<snip> 
Running anaconda, the Fedora Core system installer 
Probing for video card: ATI Technologies Mobility Inc Radeon Mobility X700 
(PCIE) 
Probing for monitor type: Uknown monitor 
 
 Graphical install -> Boot hangs when starting X       
 Text install      -> Messed up menus   
 
 
   
   
   
Comment 16 Philip Trickett 2006-03-08 13:02:49 EST
I have this working now on the readeon server. Reference this post:
https://www.redhat.com/archives/fedora-test-list/2005-December/msg00248.html

It seems the radeon driver mixes up the displays, and enables the externat
analog output instead of the internal panel.

I will attach my xorg.conf for reference.
Comment 17 Philip Trickett 2006-03-08 13:04:08 EST
Created attachment 125822 [details]
Configuration working at native resolution on flat panel
Comment 18 WangKeMeng 2006-03-09 00:56:33 EST
I update kernel,kudzu,firstboot, system-config-display from rawhide, all of them
hang my machine(Ferrari 4002), have you tested those package on your Ferrari 4005?
I find that anaconda have a flage to force the use of the vesa driver:)I expect
firstboot & system-config-display should not hang kernel on FC5 final release.

kernel-2.6.15-1.2032_FC5
kudzu-1.2.34.1-1
firstboot-1.4.6-1
system-config-display-1.0.37-1

Comment 19 Mike A. Harris 2006-03-09 02:46:02 EST
(In reply to comment #17)
> Created an attachment (id=125822) [edit]
> Configuration working at native resolution on flat panel

These options:
        Option	    "MonitorLayout" "LVDS,NONE"
	Option	    "PanelSize" "1680x1050"

are the solution for the problem, which indicates that this is a case of the
driver being unable to autodetect the display types connected to it, and unable
to detect the panel size.

These options are only required in cases that the driver can not
autodetect the display type, and if that is the case, it is not possible
to know what display type is connected in order to automatically add the
options in the config tool.  This is why they must be manually specified
by the user.

Please file a bug report in X.Org bugzilla for this issue, against the
"radeon" driver.  Until the driver's display detection logic is reworked
to autodetect more hardware properly, the MonitorLayout and other options
may need to be manually specified in the config file by the user.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.

Comment 20 Philippe Rigault 2006-03-09 08:19:00 EST
> Please file a bug report in X.Org bugzilla for this issue 
OK, I will do this. 
  
> Until the driver's display detection logic is reworked  
> to autodetect more hardware properly, the MonitorLayout and other options  
> may need to be manually specified in the config file by the user.  
  
And the user should be able to specify them during the install.  
  
Which makes me think of a better approach for the installer:  
The installer should first try to autodetect, then present its findings to the  
user in a menu like this:  
  
 Display: <display found>  
 Other stuff (size,resolution)  
  
 Graphical install    
 Text install   
 Cancel  
  
The 'Text install' should be there to make it possible to proceed with a text  
install at this point.  
  
  
  
Comment 21 Philippe Rigault 2006-03-09 08:49:17 EST
It is: 
https://bugs.freedesktop.org/show_bug.cgi?id=6195 
Comment 22 Jan-Petter Vainionpaa 2006-03-22 15:14:54 EST
The graphical install is still broken with FC 5. Tried to install official AMD64
DVD image to my laptop (details of laptop can be seen above in comment 10).
Graphical install hung, but text mode seems to work now.
Comment 23 Kyle Pablo 2006-03-26 23:43:41 EST
hello, 

there is a work around. using 'linux vesa' will solve the graphical install.
after installing FC5 i tried using the radeon driver and it still does not work.  

Note:  This is on the Acer Ferrari 4005.
Comment 24 Kyle Pablo 2006-03-31 13:07:50 EST
Created attachment 127141 [details]
Xorg.conf file / works with radeon x700.
Comment 25 Jan-Petter Vainionpaa 2006-04-03 15:58:17 EDT
Created attachment 127254 [details]
Photo taken after X has been started.

After succesfull text mode installing I have been trying to get the X working.
Many thanks for the comments and suggestions presented here. First X did not
start at all, but after following your instructions I was able to launch the X
on my F-S Amilo A1667-G20, unfortunately it's still hardly readable as can be
seen from the attached image I took with my digital camera :)

I'll also attach the xorg.conf which gave me these results. Is there anything I
could do to help to get this fixed? Take logs or something?
Comment 26 Jan-Petter Vainionpaa 2006-04-03 16:04:41 EDT
Created attachment 127255 [details]
The xorg.conf file I used to get X working poorly
Comment 27 Jan-Petter Vainionpaa 2006-04-13 10:28:17 EDT
Created attachment 127708 [details]
I have modified this file from its original content
Comment 28 Jan-Petter Vainionpaa 2006-04-13 10:33:21 EDT
The xorg.conf file in comment 27 is the one with which I got the X working with
FC 5 default radeon driver on my F-S Amilo A1667G-20 laptop (using kernel
2.6.16-1.2080_FC5). I got help from Open SuSE 10.1 B9 installer, which created
the xorg.conf file containing needed ModeLine and refresh rate information.
Comment 29 Mike A. Harris 2006-06-14 12:44:40 EDT
Our bugzilla database had a catastrophic failure on June 13, 2006
which lost all bug changes from Thurs June 9th through 13th.  I have
bugzilla email records of the time period however, and will be
restoring as many changes as I can manually.

Comment 30 Mike A. Harris 2006-06-14 12:46:03 EDT
(In reply to comment #20)
>> > > Please file a bug report in X.Org bugzilla for this issue 
> > OK, I will do this. 

Thanks.

>> > > Until the driver's display detection logic is reworked  
>> > > to autodetect more hardware properly, the MonitorLayout and other options  
>> > > may need to be manually specified in the config file by the user.  
> >   
> > And the user should be able to specify them during the install.  
> >   
> > Which makes me think of a better approach for the installer:  
> > The installer should first try to autodetect, then present its findings to the  
> > user in a menu like this:  
> >   
> >  Display: <display found>  
> >  Other stuff (size,resolution)  
> >   
> >  Graphical install    
> >  Text install   
> >  Cancel  
> >   
> > The 'Text install' should be there to make it possible to proceed with a text  
> > install at this point.  

Feel free to file an enhancement request against the anaconda component
if this is a feature you are interested in.  That way the anaconda team
will see your request and take it into consideration.
   
(In reply to comment #21)
> > It is: 
> > https://bugs.freedesktop.org/show_bug.cgi?id=6195 

That bug has been closed as a duplicate of:
https://bugs.freedesktop.org/show_bug.cgi?id=5386

We will track the problem in the upstream bug report now.  Any future followups
to this report should happen in the X.Org bugzilla.

Setting status to UPSTREAM.




Note You need to log in before you can comment on or make changes to this bug.