Bug 182944 - FC4 install fails on sda formatting
FC4 install fails on sda formatting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 12:19 EST by Nook Schreier
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 11:38:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nook Schreier 2006-02-24 12:19:44 EST
Description of problem:
I'm trying to install Fedora Core 4 on an IBM Netfinity 3000.  At first there
was a video card problem (S3 driver) but I installed a new video card (RIVA
TNT2), so I don't believe it is related, but I mention it just in case.
After going through the initial setup config, it tries to partition /dev/sda
(8GB SCSI HD on AHA-2940U2B), but for every partition on it (/, /boot, swap,
/usr, /tmp) I get an error:

Error: Error informing kernel about modifications to partition /dev/sda(#) -
Device or resource busy.  This means Linux won't know about any changes you made
to /dev/sda(#) until you reboot [...]

Then it does a shutdown, leading to "You may safely reboot your system"

Of course, the value of (#) changes for each partition

Version-Release number of selected component (if applicable):
Other bug reports said the error came from parted, this particular version is
included with Fedora Core 4

How reproducible:
Unknown, do not have a comparable computer to test with

Steps to Reproduce:
1.Boot from Fedora Core 4 Disc 1 (of 4, all disks tested correctly)
2.Partition sda SCSI disk
3.Formatting seems to be where it fails
  
Actual results:
Installation failure, SCSI HD partitioned, but partitions not formatted (nor are
the volume labels applied)

Expected results:
Partitioning, formatting, Continued installation

Additional info:
Other partitions (/home, etc) are on /dev/hda1.  I do not know if it would
format correctly, the installer starts with the SCSI HD and fails before it gets
to try.
Comment 1 Nook Schreier 2006-02-24 13:42:07 EST
Removed all SCSI hardware, installed new IDE drive, hdb.  Now hdb fails with the
same error.  I tried to save the crash dump, but when I use "save to floppy" it
brings up the "Please insert floppy" dialog.  When I click OK it does something
with the disk and the window pops back up.  Nothing is written to the disk.  It
isn't write-protected, it was formatted in Win2000.  Anyway, the error is in
partedUtils.py, line 726 in savePartitions: disk.commit()

I've never installed Fedora Core, but have never had any problems installing
Linux before (maybe a dozen installs, starting with RH5.0).
Comment 2 David Cantrell 2006-02-24 13:46:31 EST
Since we're frozen while we close bugs for the upcoming FC5 release, can you
test with FC Test 3 and see if this problem shows up there?
Comment 3 Nook Schreier 2006-02-24 14:34:15 EST
Sure thing, is that FC-5-Test3-disc[1-5], AKA 4.92?
Comment 4 David Cantrell 2006-02-24 14:38:47 EST
Correct.  The release that's in this directory:

http://download.fedora.redhat.com/pub/fedora/linux/core/test/4.92/
Comment 5 Nook Schreier 2006-02-27 11:38:04 EST
Short answer: it works

Long answer:
OK, I downloaded the ISOs over the weekend, burned and tested them this morning.
 After they tested OK, I proceeded with the install and it said I don't have
enough RAM to run the graphical installer, so it ran the textmode installer, but
the text menus (Welcome to Fedora Core! [OK] [BACK]) are all messed up.  Hard to
describe how it's messed up...  The window titles all start with a J with a ^
over it and end with a black rectangle.  The lines that have buttons on them are
shorter, as if the red characters were deleted.  The drop shadows are completely
off.  But that's an entirely different bug and is probably not an issue for most
users.

It appears that the partitioning formatting work properly for my system in FC5
test3.  Thanks.  (Sorry if I changed the bugzilla status incorrectly,
NEXTRELEASE seemed most appropriate)
Comment 6 David Cantrell 2006-02-27 13:06:02 EST
Thanks for testing that out.  Glad it worked for you under test 3.  Regarding
the screwed up display with J and ^ and such... I was working on that problem
last week and it should be taken care of in rawhide now.

Closed as NEXTRELEASE is probably ok, but in an effort to maintain consistency,
I'm changing it to closed RAWHIDE which is how we usually close these bug reports.

Thanks again.

Note You need to log in before you can comment on or make changes to this bug.