Bug 182945 - weak ciphertext when used with block encryption algorithms
weak ciphertext when used with block encryption algorithms
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Crypt-CBC (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 12:21 EST by Dennis Gilmore
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 14:41:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2006-02-24 12:21:21 EST
http://www.securityfocus.com/archive/1/425966  
 
a high rated vunereability exists in perl-Crypt-CBC. 
 
Synopsis 
 -------- 
  
 The Perl Crypt::CBC module versions through 2.16 produce weak 
 ciphertext when used with block encryption algorithms with blocksize > 
 8 bytes. 
 
Please update to version 2.17
Comment 1 Andreas Thienemann 2006-02-24 14:41:55 EST
Thx for the report. Updates Packages are being pushed to the repo.
Comment 2 Dennis Gilmore 2006-02-24 15:36:25 EST
no problems,  thanks for the quick response 

Note You need to log in before you can comment on or make changes to this bug.