Bug 182949 - GNOME Power Manager Quits at startup.
GNOME Power Manager Quits at startup.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
5
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 12:58 EST by Brian Durant
Modified: 2013-03-13 00:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-11 18:03:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Durant 2006-02-24 12:58:25 EST
Description of problem:

After log in as user or as root, I receive the following error message:

"The Application 'gnome-power-manager' has quit unexpectedly."

Version-Release number of selected component (if applicable):

Unknown.

How reproducible:

Every time.

Steps to Reproduce:
1. Simply log in.
2.
3.
  
Actual results:

Unknown.

Expected results:

Unknown.

Additional info:
Comment 1 Richard Hughes 2006-02-24 13:33:06 EST
g-p-m will not work if you log in as root as the dbus session daemon has not
been started.

Please see: http://www.gnome.org/projects/gnome-power-manager/bugs.html

Richard.
Comment 2 Brian Durant 2006-02-24 13:51:11 EST
OK, but why do I have exactly the same symptom when I am logged in as a user? I
only tried to log in as root once to confirm the same symptom.

Brian
Comment 3 Richard Hughes 2006-02-24 14:15:44 EST
Can you provide the verbose log of g-p-m please, and the version of g-p-m.
There's not a lot of information in your bug. What hardware have you got, have
you done any updates etc?
Comment 4 Brian Durant 2006-02-24 14:27:41 EST
Sorry, I'm a newbie. I have a G5 tower single (PowerMac 9.1). FC is installed on
#1 SATA drive and OS X on SATA drive #2. The only thing I have done since I
installed the system, was run 'yum update'. I don't know anything about the
other things you mention.
Comment 5 Richard Hughes 2006-02-24 14:37:21 EST
>Sorry, I'm a newbie.

Then I'll let you off... :-)

Can you log in as a user, and open a console.

There, type this:

killall gnome-power-manager
gnome-power-manager --verbose --no-daemon

and copy-paste the output into a new text file (all of it), then attach this new
file to this bug report. The error should be pretty obvious if it's crashing.

Thanks a lot.
Comment 6 Brian Durant 2006-02-24 15:59:59 EST
Whew, that's good to know :-) OK, here you go:

$ killall gnome-power-manager
gnome-power-manager: no process killed
$ gnome-power-manager --verbose --no-daemon
[gpm_debug_init] gpm-debug.c:116 (21:45:49):     Debugging enabled
*** WARNING ***
[main] gpm-main.c:183 (21:45:49):        Failed to connect to socket
/var/run/dbus/system_bus_socket: No such file or directory
GNOME Power Manager has encountered a non-critical warning.
Consult http://bugzilla.gnome.org/buglist.cgi?product=gnome-power-manager for
any known issues or a possible fix.
Please file a bug with this complete message if not present
*** WARNING ***

** ERROR **: This program cannot start until you start the dbussystem daemon
This is usually started in initscripts, and is usually called messagebus
It is STRONGLY recommended you reboot your compterafter restarting messagebus


aborting...

I hope that helps.

Brian
Comment 7 Richard Hughes 2006-02-25 10:35:18 EST
What's the output of:

/sbin/service messagebus status

If this is stopped, have you enabled messagebus in system-config-services?

Thanks.
Comment 8 Brian Durant 2006-02-25 17:21:15 EST
Here is the output:

$ /sbin/service messagebus status
dbus-daemon (pid 2697) is running...

Sorry, I don't know what to stop or how to enable messagebus. Still a newbie :-)
Comment 9 Richard Hughes 2006-02-25 17:57:47 EST
Does this work with SElinux turned off (system-config-securitylevel)?
Have you done all the updates to FC5T3 (yum update)?
What is your installed version of g-p-m (rpm -qa | grep gnome-power-manager)?

Thanks.
Comment 10 Brian Durant 2006-02-26 04:29:59 EST
gnome-power-manager-2.13.91-1

I am not sure if SElinux is on or off. This may be another bug. Administration
-> Security Level. Icon in panel only comes on when I access "security level"
and goes off again when I leave. The panel itself states that SELinux is active.
Comment 11 David 2006-02-27 23:08:11 EST
I also have the same problem with gnome-power-manager, however after filling out
the bug report, and having the file saved. 
I have noticed that my terminal window and any other window applications that I
open up the top portion on the window where it displays the window name and the
application of the window that I opened up (the one right abow the toolbar-
file-edit-view-go) does not exist and it is covering up the gnome panel. I can't
move the window or do anything with it... I can't even access my Gnome menue or
any other icons on my desktop. It's is glued on to the panel. Is this some kind
of bug that needs to be looked at... I all the current updates on my computer...

Here's a copy of the bug report I have saved on my computer:
unexpected gnome-power-manager crash/quit unexpectedly
From: 
To: 
submit@bugs.gnome.org
  Date: 
   
Distribution: Fedora Core release 4.92 (Pre-FC5)
Package: planner
Severity: critical
Version: GNOME2.13.91 0.13
Gnome-Distributor: Red Hat, Inc
Synopsis: unexpected gnome-power-manager crash/quit unexpectedly
Bugzilla-Product: planner
Bugzilla-Component: General
Bugzilla-Version: 0.13
BugBuddy-GnomeVersion: 2.0 (2.13.3)
Description:
Description of the crash:
when loging into gnome after installing fedora and after the reboot the
application quits unexpectedly

Steps to reproduce the crash:
1. logging into gnome   
2. goes through the fedora loading box
3. suddenly the window comes up saying "The Application
"gnome-power-manager" has quit unexpectedly"

Expected Results:
bug existing the programm loading process

How often does this happen?
everytime in log into gnome

Additional Information:
release of patch and bug fix would help stabalize the application


Debugging Information:

Backtrace was generated from '/usr/bin/gnome-power-manager'

(no debugging symbols found)
Using host libthread_db library "/lib/i686/nosegneg/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its
symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208592720 (LWP 2975)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00a07402 in __kernel_vsyscall ()
#0  0x00a07402 in __kernel_vsyscall ()
#1  0x0044ea03 in __waitpid_nocancel ()
   from /lib/i686/nosegneg/libpthread.so.0
#2  0x00346086 in gnome_init_with_popt_table ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00a07402 in __kernel_vsyscall ()
#5  0x00ff2309 in raise () from /lib/i686/nosegneg/libc.so.6
#6  0x00ff3943 in abort () from /lib/i686/nosegneg/libc.so.6
#7  0x00cc9b72 in g_logv () from /usr/lib/libglib-2.0.so.0
#8  0x00cc9ba9 in g_log () from /usr/lib/libglib-2.0.so.0
#9  0x08050333 in ?? ()
#10 0x00fdf7a4 in __libc_start_main () from
/lib/i686/nosegneg/libc.so.6
#11 0x0804c2e1 in ?? ()

Thread 1 (Thread -1208592720 (LWP 2975)):
#0  0x00a07402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0044ea03 in __waitpid_nocancel ()
   from /lib/i686/nosegneg/libpthread.so.0
No symbol table info available.
#2  0x00346086 in gnome_init_with_popt_table ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00a07402 in __kernel_vsyscall ()
No symbol table info available.
#5  0x00ff2309 in raise () from /lib/i686/nosegneg/libc.so.6
No symbol table info available.
#6  0x00ff3943 in abort () from /lib/i686/nosegneg/libc.so.6
No symbol table info available.
#7  0x00cc9b72 in g_logv () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x00cc9ba9 in g_log () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x08050333 in ?? ()
No symbol table info available.
#10 0x00fdf7a4 in __libc_start_main () from
/lib/i686/nosegneg/libc.so.6
No symbol table info available.
#11 0x0804c2e1 in ?? ()
No symbol table info available.
Comment 12 Brian Durant 2006-02-28 05:57:49 EST
The problem with the windows is not something that I am experiencing, but to get
the windows out from under the panel, you should try to press the option (ALT)
key and click and drag with the left mouse button. This can also be used if your
display isn't set correctly and you need to make changes in the preferences and
can't see the buttons because the windo takes up too much desktop space.
Comment 13 John (J5) Palmieri 2006-02-28 16:48:26 EST
can you check to see if you have dbus-daemon in /usr/bin?  If so run rpm -qf
/usr/bin/dbus-daemon on it.  Thanks.
Comment 14 Brian Durant 2006-03-01 13:21:03 EST
Nope, it isn't there.
Comment 15 John (J5) Palmieri 2006-03-01 13:39:51 EST
Ok, well one of the problems that caused this with one of our developers was
that he had two version of the daemon that were ABI incompatable due to a failed
upgrade (he upgraded and turned off his computer in the middle).  Doesn't seem
to be your issue though.  

Have you upgraded to the latest rawhide to see if it is still broken in the
latest builds?  Thanks.
Comment 16 Brian Durant 2006-03-03 09:14:35 EST
Yup, still broken.
Comment 17 Richard Hughes 2006-03-03 09:45:15 EST
Can you try CVS for me please? There's lots of fixes in CVS, namely an important
fix for using DBUS 0.61, and plenty of others.
Comment 18 Brian Durant 2006-03-03 10:17:51 EST
How do I do that (newbie) and after I have done this once, how do I change the
repositories back to what they are now? I don't want my system to live on the
bleeding edge forever :-)

Cheers.
Comment 19 Richard Hughes 2006-03-05 11:39:44 EST
You can grab the newest package from rawhide now.
Comment 20 Brian Durant 2006-03-05 15:00:55 EST
Thanks. I did that now I get this message at startup:

"Power Manager

This program cannot start until you start the dbus system service.

This is usually started by your operating system by default, and is normally
called messagebus.

It is strongly recommended you reboot your compter after starting messagebus."

Also still seeing udev and dbus error messages at boot.
Comment 21 Brian Durant 2006-03-05 15:03:01 EST
I forgot to mention that I have noticed some libs are installed on my system in
"ppc" and "ppc64" versions. Not sure when that happened, but could that have
something to do with this issue as well?
Comment 22 Richard Hughes 2006-03-05 15:11:01 EST
You need to fix dbus before g-p-m will run.
Comment 23 Brian Durant 2006-03-05 15:29:55 EST
How?
Comment 24 Richard Hughes 2006-03-11 18:03:31 EST
>How?

If this bug is still present in FC5 release, then please re-open.

>How do I do that (newbie)

I'm not sure you should be using rawhide if you describe yourself as a newbie.

Sorry I can't be more help, Richard.

Note You need to log in before you can comment on or make changes to this bug.