Bug 182958 - failed to set 0600 permissions on password file /etc/samba/smbpasswd
failed to set 0600 permissions on password file /etc/samba/smbpasswd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 13:28 EST by Gary K. Avery
Modified: 2014-08-31 19:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 14:17:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smbd log file on FC4 machine: peabody (4.67 KB, text/plain)
2006-02-24 13:50 EST, Gary K. Avery
no flags Details
smbd log file for inbound connection from windows pc: gary_ibm (2.73 KB, text/plain)
2006-02-24 13:51 EST, Gary K. Avery
no flags Details

  None (edit)
Description Gary K. Avery 2006-02-24 13:28:06 EST
Description of problem:
when smbd starts, it produces the following log message in smbd.log:
[2006/02/24 12:47:59, 0] passdb/pdb_smbpasswd.c:startsmbfilepwent(279)
  startsmbfilepwent_internal: failed to set 0600 permissions on password file
/etc/samba/smbpasswd. Error was Permission denied
  .Unable to open passdb database.

smbd process does start though and is still running after this error produced.
windows pc boxes are able to connect to smbd process but not authenticate.
i have tried changing permissions to 777 on both smbpasswd as well as /etc/samba
but to no avail.  seen other posted discussion about this problem but no fixes.
ironically, if i remove smbpasswd and restart smbd, it has no problem creating
the file but then complains about the 0600 permissions problem again.


Version-Release number of selected component (if applicable):
samba-3.0.14a-2


How reproducible:
every time i start smbd.


Steps to Reproduce:
1. /etc/init.d/smb start
2.
3.
  
Actual results:
0600 permissions error produced in /var/log/samba/smbd.log


Expected results:
that it would start successfully and actually work as intended...


Additional info:
is there a workaround in lieu of a fix?
Comment 1 Gary K. Avery 2006-02-24 13:50:37 EST
Created attachment 125197 [details]
smbd log file on FC4 machine: peabody
Comment 2 Gary K. Avery 2006-02-24 13:51:40 EST
Created attachment 125199 [details]
smbd log file for inbound connection from windows pc: gary_ibm
Comment 3 Gary K. Avery 2006-02-24 13:54:28 EST
attached log files are based on following smb.conf debuglevel:
    debuglevel = 1 passdb:10
Comment 4 Gary K. Avery 2006-02-24 14:16:10 EST
never mind... had SELinux disabled (firewall anyways) but still had to change
setting to also disable SELinux protection for smbd daemon.  works fine now.

Note You need to log in before you can comment on or make changes to this bug.