Bug 182978 - kernel-2.6.15-1.1977_FC5smp.i686.rpm
kernel-2.6.15-1.1977_FC5smp.i686.rpm
Status: CLOSED DUPLICATE of bug 182731
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 15:53 EST by bkyoung
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-26 18:18:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkyoung 2006-02-24 15:53:45 EST
Description of problem:
2.6.15-1.1977_FC5smp
PS2 integrated pointing device (Logitech M-C48 and others) locks up kernel at
startup.

input: PS2++ Logitech Wheel Mouse as /class/input/input1

Then reports some lost information.

For both
2.6.15-1.1977_FC5smp
2.6.15-1.1975_FC5smp

GNOME reports, incorrectly, that the internet connection has been disconnected.


Version-Release number of selected component (if applicable):
2.6.15-1.1977_FC5smp
2.6.15-1.1975_FC5smp

How reproducible:
Every time.

Steps to Reproduce:
1. Boot using 2.6.15-1.1977smp kernel
  
Actual results:
Lockup

Expected results:
Similar to kernel-2.6.15-1.1975smp, and boot successfully.

Additional info:
Should the diff be:
KOBJ_OFFLINE	= (__force kobject_action_t) 0x06,	/* device offline */
KOBJ_ONLINE	= (__force kobject_action_t) 0x07,	/* device online */

diff -r
/home/bkyoung/proj/k1977/BUILD/kernel-2.6.15/linux-2.6.15.i686/include/linux/kobject.h
/home/bkyoung/proj/k1975/BUILD/kernel-2.6.15/linux-2.6.15.i686/include/linux/kobject.h
44,47c44,45
< 	KOBJ_MOUNT	= (__force kobject_action_t) 0x04,	/* mount event for block
devices (broken) */
< 	KOBJ_UMOUNT	= (__force kobject_action_t) 0x05,	/* umount event for block
devices (broken) */
< 	KOBJ_OFFLINE	= (__force kobject_action_t) 0x06,	/* device offline */
< 	KOBJ_ONLINE	= (__force kobject_action_t) 0x07,	/* device online */
---
> 	KOBJ_OFFLINE	= (__force kobject_action_t) 0x04,	/* device offline */
> 	KOBJ_ONLINE	= (__force kobject_action_t) 0x05,	/* device online */
Comment 1 Dave Jones 2006-02-26 18:18:15 EST

*** This bug has been marked as a duplicate of 182731 ***

Note You need to log in before you can comment on or make changes to this bug.