Bug 182993 - Text modes garbled after runlevel 5 is reached
Text modes garbled after runlevel 5 is reached
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 182994 182995 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 20:00 EST by bob_inge_a
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 6.8.2-37.FC4.49.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 11:52:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested conf file (2.73 KB, application/octet-stream)
2006-02-27 18:05 EST, bob_inge_a
no flags Details
requested log file (34.15 KB, text/x-log)
2006-02-27 18:07 EST, bob_inge_a
no flags Details
content of lspci call, as requested (1.45 KB, application/octet-stream)
2006-02-27 18:08 EST, bob_inge_a
no flags Details

  None (edit)
Description bob_inge_a 2006-02-24 20:00:53 EST
Description of problem:
After reaching runlevel 5 (Diamond 2000 3D video adapter) everything runs great 
until a virtual console is opened, telinit 3 is run from a terminal, or the 
system is shut down.  Instead of a text screen, I get a graphics image -- a 
pink border around a rectangle filled with vertical blue and black stripes, but 
an effort to place text into the rectangle is seen in a garbled form.  I 
intalled Fedora Core 2 and the system runs correctly, so it appears to be a 
problem between X11 and the kernel with this video card.  I reinstalled FC4 
several times from several different sets of disks, and this unwanted behavior 
occurred every time.  If I boot to runlevel 3, things are normal until I start 
X.

Version-Release number of selected component (if applicable):


How reproducible:
See above.  On my machine, any action to get to what should be a text screen 
from an X session (terminal 7) results in a garbled screen.

Steps to Reproduce:
1.start X
2.open a virtual console, run telinit 3, or shut down
3.
  
Actual results:


Expected results:


Additional info: I know this is weird.  I see no bug about it, and my post on
fedora forum produced no insight into the problem.  I would think it was 
hardware related except that the hardware runs fine in FC 2.  I would much 
rather be running FC4 for its software and appearance.  I hope FC 5 will not 
have this problem.
Comment 1 Frank Arnold 2006-02-25 08:39:50 EST
*** Bug 182994 has been marked as a duplicate of this bug. ***
Comment 2 Frank Arnold 2006-02-25 08:40:24 EST
*** Bug 182995 has been marked as a duplicate of this bug. ***
Comment 3 Olivier Baudron 2006-02-27 11:04:17 EST
Please, provide:
- the version of xorg-x11 on your system
- the relevant part of 'lspci -v'
- /etc/X11/xorg.conf and /var/log/Xorg.0.log as attachments
Comment 4 bob_inge_a 2006-02-27 15:04:40 EST
(In reply to comment #3)
> Please, provide:
> - the version of xorg-x11 on your system
> - the relevant part of 'lspci -v'
> - /etc/X11/xorg.conf and /var/log/Xorg.0.log as attachments

e-mail with attachments sent to above address.  I do not see how
I could make attachments here.  (bob_inge_a@earthlink.net)
Comment 5 Mike A. Harris 2006-02-27 15:21:05 EST
Attachments must be submitted directly into bugzilla as individual uncompressed
file attachments, using the "Create a New Attachment" link below, just above
"External Bugzilla References".

We can't track stuff sent via email, so email submissions are not accepted.
Comment 6 bob_inge_a 2006-02-27 18:05:07 EST
Created attachment 125360 [details]
requested conf file
Comment 7 bob_inge_a 2006-02-27 18:07:17 EST
Created attachment 125361 [details]
requested log file
Comment 8 bob_inge_a 2006-02-27 18:08:19 EST
Created attachment 125362 [details]
content of lspci call, as requested
Comment 9 Olivier Baudron 2006-02-28 03:25:46 EST
From e-mail: xorg-x11 version is 6.8.2-31.
Please, upgrade to x11-6.8.2-37.FC4.49.2 and see if it works.
Comment 10 bob_inge_a 2006-03-01 11:24:52 EST
(In reply to comment #9)
> From e-mail: xorg-x11 version is 6.8.2-31.
> Please, upgrade to x11-6.8.2-37.FC4.49.2 and see if it works.

I did upgrade as suggested, and the problem is resolved with
the upgrade.  I thank Olivier Baudron for useful advice on this.
This thread can be closed.

Note You need to log in before you can comment on or make changes to this bug.