Bug 18300 - (initscript or maybe even a kernel bug, where some subinterfaces do not respect the default route.
(initscript or maybe even a kernel bug, where some subinterfaces do not respe...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 02:44 EDT by shane
Modified: 2014-03-16 22:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-22 15:47:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shane 2000-10-04 02:44:15 EDT
I have a redhat 7.0 server with 10 sub interfaces (eth0:1 - eth0:10) 
my /etc/sysconfig/network-scripts/ifcfg-eth0:x interfaces look like so:
DEVICE=eth0:1
BOOTPROTO=none
BROADCAST=209.221.163.127
IPADDR=209.221.163.71
NETMASK=255.255.255.192
NETWORK=209.221.163.64
ONBOOT=yes

After a reboot or /etc/init.d/network restart some sub interfaces lose 
their ability to comunicate with any network nodes not on the local subnet.

This has happend both times I have rebooted and only start working after 
about 30 /etc/init.d/network restarts/ifdown/ifups's until finally one of 
the sub interfaces come up.

It seems like after the system is restarted some sub-interfaces do not get 
assigned a default gateway.  I have tried adding "GATEWAY" 
and "GATEWAYDEV" as well as playing with "BOOTPROTO" but with no luck.

I would be willing to provide access to this box if needed.

My email is:
shane@geeklords.org
Comment 1 Bill Nottingham 2000-10-04 14:35:15 EDT
What does your routing table look like?
Comment 2 shane 2000-10-04 15:11:32 EDT
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
209.221.163.64  *               255.255.255.192 U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         209.221.163.65  0.0.0.0         UG    0      0        0 eth0

This is how the route tabled looked when it is NOT working as well.
Comment 3 Christopher Johnson 2000-10-05 00:02:46 EDT
Do you have an ifcfg-eth0 file?
What did your /etc/sysconfig/network script look like with GATEWAY and
GATEWAYDEV added?
Comment 4 shane 2000-10-05 03:23:03 EDT
[shane@master shane]$ cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=master.geeklords.org
GATEWAY=209.221.163.65
GATEWAYDEV=eth0

This file was created by a redhat 7.0 fresh install, the only files I played 
with are the ones I created (i.e. the sub interface files eth0:x).

Redhat 7.0 install also created a /etc/sysconfig/network-scripts/ifcfg-eth0 and 
it looks like this:
DEVICE=eth0
BOOTPROTO=static
BROADCAST=209.221.163.127
IPADDR=209.221.163.98
NETMASK=255.255.255.192
NETWORK=209.221.163.64
ONBOOT=yes

I noticed this problem after doing a default server install and then 
aimmediately creating the ifcfg-eth0:x files.  I should be able to reproduce 
the problem merely by rebooting.

I can give you an account on the machine if it helps, email me with an account 
if you would like to take this route.

Comment 5 shane 2000-10-10 22:39:39 EDT
Is there any other information you require?
Comment 6 Behdad Esfahbod 2004-01-23 04:17:26 EST
This report is really old now.  I don't think it's kinda that can be
tested and reproduced on a newer system easily.  Better closed?
Comment 7 Bill Nottingham 2005-02-22 15:47:03 EST
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please reopen if it persists on current releases.

Note You need to log in before you can comment on or make changes to this bug.