Bug 183027 - ps/2 keyboard will not work with the 2.6.15 kernel
ps/2 keyboard will not work with the 2.6.15 kernel
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-02-25 11:13 EST by Jared Hogrefe
Modified: 2008-01-19 23:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-19 23:39:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Full dmesg (20.92 KB, text/plain)
2006-03-09 05:02 EST, René Ribaud
no flags Details

  None (edit)
Description Jared Hogrefe 2006-02-25 11:13:33 EST
Description of problem: ps/2 keyboard will not work with the 2.6.15 kernel
I have an SMP system but habve tried both SMP and non-SMP.
The following have failed:

The following works fine without issue:

Version-Release number of selected component (if applicable):

How reproducible: Everytime

Steps to Reproduce:
1.Have grub load a 2.6.15 kernel
Actual results:
Keyboard fails to work.

Expected results:
Keyboard to work.

Additional info:
Comment 1 René Ribaud 2006-03-09 05:02:47 EST
Created attachment 125864 [details]
Full dmesg
Comment 2 René Ribaud 2006-03-09 05:03:43 EST
I have a similar pb but on x86_64 :

Keyboard not available --> i8042.c: Can't read CTR while initializing i8042.

kernel-2.6.15-1.1831_FC4.x86_64 and kernel-2.6.15-1.1833_FC4.x86_64

Upgrading to 2.6.15-1*.x86_64, my PS2 keyboard doesn't work anymore. (mouse is ok).
It works fine with previous kernel : kernel-2.6.14-1.1656_FC4.x86_64

I have tried to use option "i8042.nomux" at boot up but it is still failing.

My motherboard is a Gigabyte : GA-K8NMF-9 nforce 4 chipset.
Bios release F7 (not the latest).
Keyboard is a classical Logitech PS/2.
Comment 3 Dave Jones 2006-09-16 22:17:17 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 4 Dave Jones 2006-10-16 17:19:28 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Jon Stanley 2008-01-19 23:39:53 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.