Bug 1830628 - python2-beautifulsoup4 should be obsoleted by something
Summary: python2-beautifulsoup4 should be obsoleted by something
Keywords:
Status: CLOSED DUPLICATE of bug 1830231
Alias: None
Product: Fedora
Classification: Fedora
Component: python-beautifulsoup4
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-03 07:18 UTC by Elliott Sales de Andrade
Modified: 2020-05-03 12:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-03 12:07:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Elliott Sales de Andrade 2020-05-03 07:18:47 UTC
Description of problem:
python2-beautifulsoup4 is no longer available on Fedora 32, but upgrades from 31 will fail because its dependency python2-lxml is also unavailable:

$ podman run --rm -it fedora:31
[root@15779061faaa /]# dnf install python2-beautifulsoup4
Dependencies resolved.
=====================================================================================
 Package                               Architecture Version         Repository Size
=====================================================================================
Installing:
 python2-beautifulsoup4                noarch       4.9.0-1.fc31    updates    195 k
Installing dependencies:
 gdbm                                  x86_64       1:1.18.1-1.fc31 fedora     127 k
 libxslt                               x86_64       1.1.34-1.fc31   updates    244 k
 python2                               x86_64       2.7.17-1.fc31   updates     42 k
 python2-backports                     x86_64       1.0-17.fc31     fedora     9.6 k
 python2-backports-functools_lru_cache noarch       1.5-6.fc31      fedora      16 k
 python2-libs                          x86_64       2.7.17-1.fc31   updates    6.0 M
 python2-lxml                          x86_64       4.4.0-1.fc31    fedora     1.4 M
 python2-soupsieve                     noarch       1.9.2-1.fc31    fedora      66 k
Installing weak dependencies:
 python2-pip                           noarch       19.1.1-7.fc31   updates    1.7 M
 python2-setuptools                    noarch       41.6.0-1.fc31   updates    584 k

Transaction Summary
=====================================================================================
Install  11 Packages

Total download size: 10 M
Installed size: 46 M
...

[root@15779061faaa /]# dnf system-upgrade download --releasever=32
...
Error: 
 Problem: package python2-beautifulsoup4-4.9.0-1.fc31.noarch requires python2-lxml, but none of the providers can be installed
  - python2-lxml-4.4.0-1.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-beautifulsoup4-4.9.0-1.fc31.noarch
(try to add '--skip-broken' to skip uninstallable packages)


Version-Release number of selected component (if applicable):
python2-beautifulsoup4-4.9.0-1.fc31.noarch


Actual results:
Upgrade fails because of conflicts.


Expected results:
python2-beautifulsoup4 should be obsoleted, by either fedora-obsolete-packages, or the python3 version.


Additional info:
https://ask.fedoraproject.org/t/dnf-upgrade-from-31-to-32-fails/6703

Comment 1 Nikolaos Perrakis 2020-05-03 11:29:22 UTC
I had the same issue when upgrading from Fedora MATE 31 to Fedora MATE 32. Manually deleted the offending package solved the problem.
There is a python3-beautifulsoup4 package and that package can (should?) be replaced with that. Actually after having manually removed the offending packaged the python3 replacement did end up installed on my system.

Looking at reverse dependencies two possible culprits are:

$ dnf repoquery --installed --whatrequires python3-beautifulsoup4
calibre-0:4.13.0-1.fc32.x86_64
translate-toolkit-0:2.5.0-1.fc32.noarch

Comment 2 Terje Røsten 2020-05-03 12:07:57 UTC
This seems to be dup of 1830231, which has fix in updates-testing. 

Use podman I get and enabling updates-testing I get:

# dnf system-upgrade download --releasever=32

...

Removing dependent packages:
 python2-backports       x86_64 1.0-17.fc31      @fedora         638  
 python2-backports-functools_lru_cache
                         noarch 1.5-6.fc31       @fedora          17 k
 python2-beautifulsoup4  noarch 4.9.0-1.fc31     @updates        1.0 M
 python2-lxml            x86_64 4.4.0-1.fc31     @fedora         5.0 M
 python2-soupsieve       noarch 1.9.2-1.fc31     @fedora         242 k

which indicate problem is solved by 1830231.

*** This bug has been marked as a duplicate of bug 1830231 ***


Note You need to log in before you can comment on or make changes to this bug.