Bug 183068 - auto completion works strange used with yum
auto completion works strange used with yum
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bash-completion (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 18:28 EST by Roland Wolters
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 20060301-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 13:21:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum updates to bash-completion (1.71 KB, patch)
2006-02-26 06:54 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Roland Wolters 2006-02-25 18:28:36 EST
Description of problem:  
  
I tried to use the autocompletion with "yum localinstall" and a rpm file and  
it didn't work although it should, because it works with the shells sh and 
zsh. 
 
I then tried the autocompletion of "yum" and "localinstall" which also didn't 
work - "yum" and two tabs give me some possibilities where for example 
groupinstall is included, but not localinstall. This should be added also. 
Btw.: the whole yum options like groupinstall do not work with zsh or sh - 
there you get only file names when you hit tab two times after the yum. 
 
So: bash should be fixed to offer the bash completion of the filenames after 
the "yum localinstall" command, and the auto completion of yum in bash should 
be fixed so that localinstall is an option also. 
 
Note: I first thought it was an error of yum and posted this bug report which 
is already closed - thanks for the fast answer there! 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=183062
Comment 1 Ville Skyttä 2006-02-26 06:54:50 EST
Created attachment 125274 [details]
yum updates to bash-completion

Yep, the yum completion stuff in bash-completion seems pretty outdated.  Here's
a patch that makes it better, I'll submit it upstream too.  Testing welcome.
Comment 2 Ville Skyttä 2006-03-09 13:21:16 EST
Should be better in 20060301-1.fc*
Comment 3 Roland Wolters 2006-03-10 21:45:53 EST
Works perfect here, thank you very much for this patch! 

Note You need to log in before you can comment on or make changes to this bug.