Bug 18309 - RFE: Add support for configuring LILO to boot from SCSI when IDE exists
RFE: Add support for configuring LILO to boot from SCSI when IDE exists
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 04:35 EDT by Cedric Maion
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 15:29:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cedric Maion 2000-10-04 04:35:22 EDT
Hello,

I've two hard drives in my box : one SCSI HD and one UDMA/IDE HD.

My BIOS is configurated to initialize my SCSI Adapter first, then the
builtin IDE controller (because my system disk is the SCSI one and I need
to boot on it).

LILO is unable to autodetect such a configuration and assume that IDE (hd*)
disks are the first one.
In order to make LILO work (i.e., to specify the correct disk order), I
need to add the following in /etc/lilo.conf (as documented in lilo tech
docs) :

disk=/dev/sda
	bios=0x80
disk=/dev/hda
	bios=0x81

The problem is that Anaconda can't be given the real order of disks and
thus generates an unusable lilo configuration (my workaround was to switch
to the shell prompt at the end of the installation, chroot /mnt/sysinstall,
vi /etc/lilo.conf and then reruning lilo -- OR, boot on the boot diskette).
Can you either add a specific configuration option to Anaconda or add a way
to specify complementary informations for lilo/lilo.conf ?
Comment 1 Michael Fulbright 2000-10-05 17:57:21 EDT
Related to bug 14975.

I have marked this as an enhancement for future development.
Comment 2 Jeremy Katz 2002-01-21 19:37:11 EST
Will be possible for the next release

Note You need to log in before you can comment on or make changes to this bug.