Bug 1831093 - No more kernel installed and script stopped with failure
Summary: No more kernel installed and script stopped with failure
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: convert2rhel
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michal Bocek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-04 16:08 UTC by jeanmichel.loubet
Modified: 2020-08-26 15:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-22 08:42:54 UTC
Type: Bug


Attachments (Terms of Use)

Description jeanmichel.loubet 2020-05-04 16:08:14 UTC
Description of problem:
I configured (badly) my repositories for RHEL 7, but the convert2rhel script did not detect this mis-configuration. The script started, removed my kernel packages and finally stopped saying it was not possible to download rhel kernel packages.

Version-Release number of selected component (if applicable):
[root@tpcdrp02s ~]# rpm -q convert2rhel
convert2rhel-0.9-1.el7.noarch


How reproducible:

Steps to Reproduce:
1. Original server is Centos 7, updated to the last version.
2. Configure bad repositories for RHEL
3. Launch procedure : convert2rhel --disable-submgr

Actual results:
Kernel (centos) packages are removed.
No one RHEL kernel packages is installed.


Expected results:
Script should stop at the very beginning, checking this issue before changing something on the server.

Additional info:

Comment 1 Michal Bocek 2020-05-05 07:59:58 UTC
Hi Jean, thanks for the report. 

The convert2rhel first tries to install the RHEL kernel and if successful remove the CentOS kernel. But I can see now there's not enough safeguards. In your case, since the options --enablerepo and --disablerepo weren't used, the convert2rhel used all the repos available/enabled on the system, including CentOS repos. So the installation of RHEL kernel most probably ended with "Nothing to do".

There are two things to improve:
- verify the kernel that convert2rhel tries to install is really a RHEL kernel (GPG key fingerprint of the package matches the RHEL fingerprint)
- to require to pass at least one --enablerepo and if no --disablerepo is passed, assume --disablerepo="*"

Comment 3 Michal Bocek 2020-06-22 08:42:54 UTC
Resolved in upstream:
- verifying the installed kernel fingerprint: https://github.com/oamg/convert2rhel/pull/45
- requiring --enablerepo with --disable-submgr: https://github.com/oamg/convert2rhel/pull/58

Comment 4 Fedora Update System 2020-08-19 15:43:36 UTC
FEDORA-EPEL-2020-d0a4bcf7f1 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d0a4bcf7f1

Comment 5 Fedora Update System 2020-08-20 02:08:24 UTC
FEDORA-EPEL-2020-baa69bfeef has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-baa69bfeef

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-08-20 02:11:44 UTC
FEDORA-EPEL-2020-d0a4bcf7f1 has been pushed to the Fedora EPEL 6 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d0a4bcf7f1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-08-22 01:52:54 UTC
FEDORA-EPEL-2020-baa69bfeef has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-08-26 15:12:26 UTC
FEDORA-EPEL-2020-d0a4bcf7f1 has been pushed to the Fedora EPEL 6 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.