Bug 183113 - PATCH: allegro doesnot find and load plugins/modules on x86_64
PATCH: allegro doesnot find and load plugins/modules on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: allegro (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 08:34 EST by Hans de Goede
Modified: 2013-07-02 19:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 04:55:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH fixing loading of plugins on 64bit (401 bytes, patch)
2006-02-26 08:34 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-02-26 08:34:52 EST
allegro searches for its plugins/modules in /usr/lib/allegro instead of
/usr/lib64/allegro

This can be seen in a strace, but also because it uses oss for sound instead of
alsa which is in a plugin. For the oss case start lacewing or overgod and then
do a dmesg, the output is:
application lacewing uses obsolete OSS audio interface

With this patch this goes away because allegro properly uses alsa. I did not
send this upstream.
Comment 1 Hans de Goede 2006-02-26 08:34:53 EST
Created attachment 125277 [details]
PATCH fixing loading of plugins on 64bit
Comment 2 Hans de Goede 2006-02-27 04:55:20 EST
Committed to CVS and build requested

Note You need to log in before you can comment on or make changes to this bug.