Bug 18312 - GNOME freezes when system coming out of suspend
GNOME freezes when system coming out of suspend
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 04:56 EDT by Shreedeep Bhachech
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 05:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shreedeep Bhachech 2000-10-04 04:56:42 EDT
Dell Inspiron 3200 Laptop.

After waking up from suspend, the mouse briefly works, but then it stops
working. Ctrl-Alt-BkSpc does not kill (and restart) the X-Server.
Ctrl-Alt-F1 thru Ctrl-Alt-F6 do not switch between the virtual consoles.
The only approach that worked for me was the simplest one: PULL THE THREE
PRONGS OUT OF SOCKET. (In my case, I also had to pop the battery since it's
a laptop.)

With 6.2, I used KDE and this didn't used to happen. Apart from the OS
upgrade, the only other thing that changed was Desktop Environment, so I
though it might just have something to do with the problem.

Any suggestions?
Comment 1 Bernhard Rosenkraenzer 2000-10-04 05:06:06 EDT
This sounds like a BIOS problem we're working around...
Does setting "CHANGEVT" in /etc/sysconfig/apmd help?
Comment 2 Shreedeep Bhachech 2000-10-04 06:14:26 EDT
I uncommented CHANGEVT line, and restarted apmd (by `/etc/rc.d/init.d/apmd
restart` command.) Then, when I suspended the system and rebooted again, it was,
so-to-say, ALIVE, as in mouse activity was being registered, and Accordingly
menus etc popped up, but the screen overall was crappy -- None of the text in
menus showed up, menus themselves were just a grey rectangle and nothing more.
The upper two corners were showing text from vt 1! 

Anyway, so I reverted back to the original file, commenting out CHANGEVT part.
Lo and behold, IT IS WORKING PERFECTLY NOW!

Maybe it wasn't a bug, maybe I encountered some glitches. But three times in a
row? Beats me.

Anywho, it works for me now, so changing the status to WORKSFORME. Thanks for
the tip, Bero!

Note You need to log in before you can comment on or make changes to this bug.