Bug 183125 - Only 21 screensavers listed in KDE's Control Center
Only 21 screensavers listed in KDE's Control Center
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 11:18 EST by Dariusz Garbowski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 09:12:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dariusz Garbowski 2006-02-26 11:18:06 EST
Description of problem:
I can see only 21 screensavers available in KDE Control Center, out of which 10
are OpenGL that not work on my hardware (they display blank screen). However if
I choose "Random" in Control Center I can see that there are definitely more
screensavers installed. Quoting Jim Cornete in related thread on fedora-test
list (https://www.redhat.com/archives/fedora-test-list/2006-February/msg01879.html)

"It impedes usability, functionality and product satisfaction.
If this is by design or accidental, it is a bug candidate."

Version-Release number of selected component (if applicable):
2.13.91-1

How reproducible:


Steps to Reproduce:
1. Log into KDE.
2. Run Control Center.
3. Go to Appearance & Themes -> Screen Saver panel.
  
Actual results:
Only 21 screensavers listed to choose from.

Expected results:
All installed screensavers should be available.

Additional info:
Comment 1 Jim Cornette 2006-02-26 11:57:13 EST
Adding to CC;
I am concerned with the lack of configurability on the GNOME side also. I
believe this problem is happening on both Available Desktops and relate to
gnome-screensaver and the not ready for release lack of configurability the
program introduces.
Comment 2 Ngo Than 2006-02-27 09:12:18 EST
It seems some xscreensaver packages are not installed on your system. You 
should install the following packages, the KDE will show more screensavers in 
the list. 
 
 xscreensaver-gl-extras-4.24-1.1 
 xscreensaver-extras-4.24-1.1 
 xscreensaver-base-4.24-1.1 
 
OpenGL screensaver (not KDE part) does not work on some hardware. It seems a 
bug in Mesa/xorg. Please fill a new bug there. Thanks 
 
Comment 3 Jim Cornette 2006-02-27 13:32:06 EST
The main issue is not being able to configure screensavers. xscreensaver-base is
not going to be installed during installations of FC5.

Are users supposed to run as root
rpm -e gnome-screensaver
yum install xscreensaver-base xscreensaver-extras and xscreensaver-gl-extras
after initial installation?

Note You need to log in before you can comment on or make changes to this bug.