Bug 183180 - seg fault
seg fault
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 02:25 EST by Florian La Roche
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 09:11:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2006-02-27 02:25:21 EST
Description of problem:

glibc was updated the last few days for fc4. I haven't checked if that
is adding problems.

If ntp is not getting dns info and dropping all servers, it will
coredump:

Feb 27 08:18:47 knorke ntpd[13279]: ntpd 4.2.0a@1.1196-r Sat Dec 17 10:34:32 CET
2005 (1)
Feb 27 08:18:47 knorke ntpd[13279]: precision = 13.000 usec
Feb 27 08:18:48 knorke ntpd[13279]: Listening on interface wildcard, 0.0.0.0#123
Feb 27 08:18:48 knorke ntpd[13279]: Listening on interface lo, 127.0.0.1#123
Feb 27 08:18:48 knorke ntpd[13279]: Listening on interface eth0, 172.20.0.2#123
Feb 27 08:18:48 knorke ntpd[13279]: kernel time sync status 0040
Feb 27 08:18:48 knorke ntpd[13279]: frequency initialized 38.121 PPM from
/var/lib/ntp/drift
Feb 27 08:19:06 knorke ntpd_initres[13207]: parent died before we finished, exiting
Feb 27 08:20:08 knorke ntpd[13279]: getaddrinfo: "0.de.pool.ntp.org" invalid
host address, ignored
Feb 27 08:21:28 knorke ntpd[13279]: getaddrinfo: "1.de.pool.ntp.org" invalid
host address, ignored
Feb 27 08:22:13 knorke ntpd[13279]: ntpd exiting on signal 15



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Florian La Roche 2006-02-27 02:45:59 EST
Masquerading was not working and thus dns failed for this host. Still ntp
should then not coredump. ??

regards,

Florian La Roche
Comment 2 Miroslav Lichvar 2006-02-27 08:33:15 EST
From PID numbers it looks like an old ntpd process has got mixed with another
one in logs, probably due to the dns timeout. Any chance you stopped ntp and in
short time run another ntp again? In such case I would say it is harmless.
Comment 3 Florian La Roche 2006-03-07 16:28:02 EST
Yes, restarted this a few times in a row.

regards,

Florian La Roche
Comment 4 Miroslav Lichvar 2006-03-27 09:11:40 EST
Ok, closing it as a NOTABUG then.

Note You need to log in before you can comment on or make changes to this bug.