Bug 183208 - file timestamps not copied to NFS directory destinations
file timestamps not copied to NFS directory destinations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 09:23 EST by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 23:56:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ethereal text dump of NFS traffic for "cp -a ~/waiver.txt ." (78.39 KB, text/plain)
2006-02-27 09:23 EST, Paul Dickson
no flags Details

  None (edit)
Description Paul Dickson 2006-02-27 09:23:32 EST
Description of problem:
If I do a "cp -a" or "mv" of a file to a remote directory accessed by NFS, the
timestamps of the source is lost.  In a NFS directory if I do a
    cp -a file1 file2
file2 will have the current time rather than the time of the original file.

Timestamps can only be copied with:
    touch -r file1 file2


Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1977_FC5

How reproducible:
Always

Steps to Reproduce:
1. Add a fstab entry with the mount options from "Additional info:" below.
2. mount the volume
3. cp -a <local>/waiver.txt <remote-nfs>/
  
Actual results:
Time is set to the current time.

Expected results:
Time set to the same time as source file.

Additional info:
Both server and client are running the same kernel version.

  Mount options:  
    defaults,owner,rw,user,auto,hard,intr,exec

I used ethereal to dump the NFS traffic for "cp -a ~/waiver.txt .".  It is
atttached below.  The client sents the mtime coorectly in Frame 12 and the
server acknowledges it in Frame 13.
Comment 1 Paul Dickson 2006-02-27 09:23:32 EST
Created attachment 125316 [details]
Ethereal text dump of NFS traffic for "cp -a ~/waiver.txt ."
Comment 2 Paul Dickson 2006-03-01 19:09:20 EST
Also in kernel-2.6.15-1.1996_FC5.

I don't believe this is a new problem, I found a script I wrote (Dec 29th) that
extracted the date/time from jpeg exif data because I lost the dates when I
moved the images to my NFS archive.

exif.py $x|head -n 20|grep "DateTime:"| \
sed -e "s/.*ASCII.\(200.\):\(..\):\(..\) \(..\):\(..\):\(..\).*/\1\2\3\4\5/"| \
xargs touch $x -t
Comment 3 Paul Dickson 2006-03-01 20:20:35 EST
http://bugzilla.kernel.org/show_bug.cgi?id=6127 has a kernel patch.
Comment 4 Dave Jones 2006-03-01 23:56:54 EST
I applied this to cvs for tonights build. should show up in builds
kernel-2.6.15-1.2006_FC5 and above.

if it doesn't make it through the buildsys in time for tomorrows rawhide push,
you can grab it early at http://people.redhat.com/davej/kernels/Fedora/devel/

Note You need to log in before you can comment on or make changes to this bug.