Bug 183276 - firstboot dying
firstboot dying
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 16:21 EST by Stuart Jansen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 15:46:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X.log from failed firstboot (1.24 KB, text/plain)
2006-02-27 16:21 EST, Stuart Jansen
no flags Details
broken XConfig.test created by firstboot (3.79 KB, text/plain)
2006-02-27 16:22 EST, Stuart Jansen
no flags Details
working xorg.conf (2.92 KB, text/plain)
2006-02-27 16:22 EST, Stuart Jansen
no flags Details
new X.log (1.25 KB, text/plain)
2006-03-06 18:28 EST, Stuart Jansen
no flags Details
new XConfig.test (3.79 KB, text/plain)
2006-03-06 18:29 EST, Stuart Jansen
no flags Details
firstboot avc denied messages (1.22 KB, text/plain)
2006-03-11 17:48 EST, Stuart Jansen
no flags Details

  None (edit)
Description Stuart Jansen 2006-02-27 16:21:27 EST
Description of problem:
Although gdm is able to start later, firstboot is dying.

Version-Release number of selected component (if applicable):
Version     : 1.4.4
Release     : 1

How reproducible:
always

Actual results:
firstboot is dying.

Expected results:
firstboot should run, even if it has to fall back to vesa 640x480 to display

Additional info:
This might be related to the fact that I have a less-common screen size: 1920x1200.
Comment 1 Stuart Jansen 2006-02-27 16:21:28 EST
Created attachment 125354 [details]
X.log from failed firstboot
Comment 2 Stuart Jansen 2006-02-27 16:22:24 EST
Created attachment 125355 [details]
broken XConfig.test created by firstboot
Comment 3 Stuart Jansen 2006-02-27 16:22:57 EST
Created attachment 125356 [details]
working xorg.conf
Comment 4 Stuart Jansen 2006-03-01 13:38:37 EST
I don't like rhgb so I didn't install it. After installing rhgb, firstboot
worked fine. Looks like firstboot tries to start its own server if rhgb isn't
running. I would suggest that it do whatever rhgb is doing to configure server.
Comment 5 Chris Lumens 2006-03-06 11:34:42 EST
I've made some modifications to make starting without rhgb better.  Please try
with FC5 and let me know if this is working for you.
Comment 6 Stuart Jansen 2006-03-06 18:27:05 EST
Unfortunately, no. I'll upload the new XConfig.test and X.log in a moment.
Comment 7 Stuart Jansen 2006-03-06 18:28:53 EST
Created attachment 125732 [details]
new X.log
Comment 8 Stuart Jansen 2006-03-06 18:29:32 EST
Created attachment 125733 [details]
new XConfig.test
Comment 9 Stuart Jansen 2006-03-11 17:47:47 EST
I just did another yum update, but it didn't fix the problem. This appears to be
an selinux issue. After switching from enforcing to permissive mode firstboot
was able start an X server. I will attach an extract from my /var/log/messages.
Comment 10 Stuart Jansen 2006-03-11 17:48:32 EST
Created attachment 126001 [details]
firstboot avc denied messages
Comment 11 Chris Lumens 2006-03-13 17:54:13 EST
You're still seeing an X server traceback, so something strange is going on in
the server itself.
Comment 12 Adam Jackson 2006-09-29 16:41:50 EDT
I haven't seen anything like this recently, and the log files given aren't
detailed enough to find where the problem is.

Reporter, if you can still reproduce this issue with FC6 test3 or later, please
update this bug with the X log file from that.
Comment 13 Stuart Jansen 2006-09-30 15:24:47 EDT
Might as well just close this bug. I won't have time to test anything for a couple of months. If I see the problem again in the future, I'll open a new bug.
Comment 14 Will Woods 2007-03-24 15:46:43 EDT
Closing based on comments.

Note You need to log in before you can comment on or make changes to this bug.