Bug 183308 - (nv-dell2001fp) Dell 2001FP (Digital) limited to max resolution of 1280x960 in System -> Preferences -> Screen Resolution
Dell 2001FP (Digital) limited to max resolution of 1280x960 in System -> Pref...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Reopened
: 162364 187216 187499 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 23:15 EST by Bill Estell
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 12:14:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (45.47 KB, text/plain)
2006-02-27 23:47 EST, Bill Estell
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 3654 None None None Never
FreeDesktop.org 4314 None None None Never

  None (edit)
Description Bill Estell 2006-02-27 23:15:27 EST
Description of problem:
Dell 2001FP connected via DVI is limited to max resolution of 1280x960 in System
-> Preferences -> Screen Resolution.  System -> Administration -> Display shows
Resolution: 1600x1200.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Connect Dell 2001FP flat panel monitor to PV via DVI.
2. Install FC5T3.
3.
  
Actual results:
Default and max resolution is 1280x960.

Expected results:
Default and max resolution is 1600x1200.

Additional info:
http://www.google.com/search?hs=U6a&hl=en&lr=&client=firefox-a&rls=org.mozilla%3Aen-US%3Aofficial&q=Fedora+Core+Linux+Dell+2001FP+DVI&btnG=Search
Comment 1 Bill Estell 2006-02-27 23:33:25 EST
Looks like this one:
https://bugs.freedesktop.org/show_bug.cgi?id=4314
Comment 2 Bill Estell 2006-02-27 23:36:23 EST
Possible duplicate of:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=162364
Comment 3 Bill Estell 2006-02-27 23:47:45 EST
Created attachment 125381 [details]
Xorg log file
Comment 4 Bill Estell 2006-02-28 09:37:54 EST
Analog works at 1600x1200 as expected.  Only digital (DVI) has problem.
Comment 5 Mike A. Harris 2006-03-01 03:21:33 EST
*** Bug 162364 has been marked as a duplicate of this bug. ***
Comment 6 josip 2006-04-01 07:21:31 EST
I see the same problem with Fedora Core 5 and a Dell 2000FP (Digital) display. 
The X server resolution is 1600x1200, but Gnome desktop is limited to 1280x960.
 This appears to be a limit imposed by /usr/bin/gnome-display-properties, not by
X configuration.

This problem was introduced in Fedora Core 5.  Fedora Core 4 used to work fine
at 1600x1200.

BTW, bug 187499 is a duplicate of this bug.
Comment 7 josip 2006-04-01 08:00:05 EST
More data: This screen resolution limit apparently comes from the "nv" display
driver, which eliminates 1600x1200 despite the xorg.conf settings, with the
following message in Xorg.0.log:

>   (II) NV(0): Mode "1600x1200" is larger than BIOS programmed panel
> size of 1280 x 1024.  Removing.

Above, the BIOS reference presumably applies to the graphics card BIOS, not the
PC BIOS.

See https://www.redhat.com/archives/fedora-list/2005-August/msg03936.html for
more detail (Andy Green recommends installing closed source nVidia driver).
Comment 8 josip 2006-04-01 14:51:34 EST
Driver NVIDIA-Linux-x86_64-1.0-8178-pkg2.run from nVidia fails to compile under
kernel-2.6.16-1.2080_FC5, although it used to build fine under FC4 kernels. 
Support for FC5 from nVidia isn't yet available.

Back to "nv" driver from xorg: Some people suggest adding the following to the
"Device" section:

  Option "IgnoreEDID" "true"

However, "nv" driver ignores this option:

  (WW) NV(0): Option "IgnoreEDID" is not used

and the end result is the same: Mode 1600x1200 gets removed by the "nv" driver.

Finally, digging through bugs at xorg, one finds
https://bugs.freedesktop.org/show_bug.cgi?id=4314 which says:

  The "nv" driver currently can't change the BIOS-programmed display timings. 
  Unfortunately, this is not something that we can fix right now.

...so all of the above suggestions terminate at dead ends.
Comment 9 Mike A. Harris 2006-06-14 10:43:38 EDT
Our bugzilla database had a catastrophic failure on June 13, 2006
which lost all bug changes from Thurs June 9th onward.  I have
bugzilla email records of the time period however, and will be
restoring as many changes as I can manually.
Comment 10 Mike A. Harris 2006-06-14 10:44:27 EDT
*** Bug 187499 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2006-06-14 11:01:34 EDT
https://bugs.freedesktop.org/show_bug.cgi?id=4314 upstream has been closed
as a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=3654, which
is where this issue is currently being tracked now.

Since this problem is aparently a bug (or limitation, or whatever) in the "nv"
driver, and it appears that it can only be fixed/resolved by Nvidia Inc.
directly, there is nothing we can do about this problem until Nvidia has
submitted patches to X.Org.

As such, we will track the issue in the upstream Xorg bugzilla until a
solution is available and go from there.

Setting status to "UPSTREAM"


Comment 12 Mike A. Harris 2006-06-14 11:02:52 EDT
*** Bug 187216 has been marked as a duplicate of this bug. ***
Comment 13 josip 2006-11-23 14:02:53 EST
Another solution for this bug is to install RPMs from Livna depository

kmod-nvidia
xorg-x11-drv-nvidia

which are built from nVidia's sources and can deliver 1600x1200 resolution.
Comment 14 Matěj Cepl 2006-11-24 12:11:42 EST

*** This bug has been marked as a duplicate of 162364 ***
Comment 15 Matěj Cepl 2006-11-24 12:12:43 EST
closed by mistake, sorry

Note You need to log in before you can comment on or make changes to this bug.