Bug 183327 - OpenMotif package is missing the libXm.so.3 file
OpenMotif package is missing the libXm.so.3 file
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: openmotif (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 04:18 EST by Ronny Bremer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 11:32:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Bremer 2006-02-28 04:18:12 EST
Description of problem:
In FC5 the openmotif package seems to include the libXm.so.4 version of the
openmotif library. For compatibility reasons it would be essential to include
either the libXm.so.3 file or build a new compat rpm to have that file.
Knwon packages to need it are for instance the Citrix ICA Client (most recent
one from citrix.com).

Version-Release number of selected component (if applicable):
openmotif.i386                           2.3.0-0.1.9.2
ICAClient-9.0-1.i386.rpm

How reproducible:
always

Steps to Reproduce:
1. install openmotif via yum
2. try to install ICAClient via yum or rpm
3.
  
Actual results:
[root@fgrbhw01 Desktop]# rpm -ivh ICAClient-9.0-1.i386.rpm
error: Failed dependencies:
        libXm.so.3 is needed by ICAClient-9.0-1.i386


Expected results:
ICAClient should get installed

Additional info:
Comment 1 Dmitry Bolkhovityanov 2006-04-23 01:00:14 EDT
I'll second that.
Previously-built programs simply wouldn't run on FC5 box without recompilation,
due to .so-files "version mismatch".

For some strange reason OpenMotif-2.3 produces libXm.so.*4* -- probably ICS
mistake, since 2.3 release is binary compatible with 2.2. Even "Release Notes"
explicitly states

    "Open Motif 2.3 is an updated version of 2.2.  Any applications
    built against a previous 2.X release of Open Motif will be binary
    compatible with this release."

The right thing was to number 2.3's .so-files as 3.1 or 3.3, but it's too late now.

Since it is very unlikely that openmotif-2.2 would be installed on FC5 box, the
best solution would be to provide ".3"-suffixed .so-files as either symlinks or,
better, as ld-script file.
Comment 2 Kevin DeKorte 2006-05-01 16:37:50 EDT
The missing libXm.so.3 library also breaks applications on my machine that
worked with FC4. I suggest a -compat lib. Makeing a symlink from libXm.so.4 to
libXm.so.3 helps, but is not a great solution.
Comment 3 Rahul Sundaram 2006-10-31 11:32:34 EST
We dont provide openmotif anymore. Closing
Comment 4 Dmitry Bolkhovityanov 2006-10-31 21:41:27 EST
Rahul, can you please explain or point me to some page describing the reasons --
WHY?!?!?!

Note You need to log in before you can comment on or make changes to this bug.