Bug 183340 - wifi not activated with 2.6.15-1830-fc4 (and 1831)
Summary: wifi not activated with 2.6.15-1830-fc4 (and 1831)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: i586 Linux
medium
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-28 12:50 UTC by Daniel Frèrejacque
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.6.16-2108-fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-22 14:29:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport (563.91 KB, application/x-bzip2)
2006-03-13 15:06 UTC, Daniel Frèrejacque
no flags Details

Description Daniel Frèrejacque 2006-02-28 12:50:32 UTC
Description of problem:until 165_FC4: wifi is assigned to eth0 (ipw2200 intel
pro) and ethernet gigabit is eth1, driver sk98lin, installed by hand.
-----
with kernel 1830: eth0 claim "sk98lin missing" activation delayed.


Version-Release number of selected component (if applicable):


How reproducible: everytime


Steps to Reproduce:
1.boot on recent kernel and wait
2.
3.
  
Actual results: eth0: sk98lin not found


Expected results: ipw2200 pro driver to be used


Additional info: using the network configuration and modification tool
trying to edit eth0: it is found that eth0 and eth1 are assigned both as
ethernet.

Going back to 1656 kernel, eth0 is wireless, eth1 is ethernet and it works fine

Comment 1 Dave Jones 2006-03-04 20:27:33 UTC
is this still a problem in kernel-2.6.15-1.1833_FC4  ? 
(Make sure you have the right firmware present too)



Comment 2 John W. Linville 2006-03-06 18:23:29 UTC
Also, please attach the output of running "sysreport" (presuming that there is 
still a problem)...thanks! 

Comment 3 Daniel Frèrejacque 2006-03-13 15:06:27 UTC
Created attachment 126042 [details]
sysreport

sysreport broke during execution due to a bad pointerCollecting information
about currently installed packages:here is the log
This may take several minutes....*** glibc detected *** /usr/lib/rpm/rpmv:
free( ): invalid pointer: 0x0a7ebc70 ***
======= Backtrace: =========
/lib/libc.so.6[0x1ce124]
/lib/libc.so.6(__libc_free+0x77)[0x1ce65f]
/lib/libselinux.so.1(freecon+0x1d)[0x6518dd]
/usr/lib/librpm-4.4.so(rpmVerifyFile+0x5ed)[0x730580]
/usr/lib/librpm-4.4.so(showVerifyPackage+0x25c)[0x730a53]
/usr/lib/librpm-4.4.so[0x70a12e]
/usr/lib/librpm-4.4.so(rpmQueryVerify+0xfb)[0x70ad9c]
/usr/lib/librpm-4.4.so(rpmcliArgIter+0x2b9)[0x70bb3e]
/usr/lib/librpm-4.4.so(rpmcliVerify+0x8f)[0x72feef]
/usr/lib/rpm/rpmv[0x8049ba2]
/lib/libc.so.6(__libc_start_main+0xdf)[0x17fd5f]
/usr/lib/rpm/rpmv[0x8049301]
........

Comment 4 John W. Linville 2006-05-22 14:29:02 UTC
Date: Sat, 20 May 2006 09:39:21 +0200 
From: "Daniel Frèrejacque" 
 <daniel.frerejacque@free.fr> 
To: linville@redhat.com 
Subject: bug 183340 
 
Solved with kernel 2108 
(1) wifi is recognized and activated 
(2) fast ethernet card driver (sk98lin) is activated 
Thank you, the bug can be removed from the list 
 
Daniel Frereajcque 
 


Note You need to log in before you can comment on or make changes to this bug.