Bug 183341 - Xorg screen with xen and radeon
Xorg screen with xen and radeon
Status: CLOSED DUPLICATE of bug 190461
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
http://adslpipe.co.uk/pics/xenradeonc...
:
: 196609 (view as bug list)
Depends On:
Blocks: 179599
  Show dependency treegraph
 
Reported: 2006-02-28 07:54 EST by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 17:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Burns 2006-02-28 07:54:58 EST
Description of problem:

Xorg radeon driver functions quite happily without xen, but with xen screen
corruption occurs, typically during the "zooming" of a new app window from the
gnome-panel. seen this in 1955 and 1977 hypervisor kernels

Version-Release number of selected component (if applicable):

kernel 2.6.15-1.1977_FC5hypervisor
xen 3.0.1-0.20060208.fc5.3
xorg-x11-drv-ati 6.5.7.3-4

How reproducible:

usually within a few minutes of using desktop

Steps to Reproduce:
1. running gnome desktop uinder hypervisor
2. launch apps (e.g. browser,email,openoffice) from shortcuts on top panel
  
Actual results:

Stray fragments of red horizontal lines left over top panel
see referenced URL
Comment 1 Daniel Veillard 2006-02-28 08:11:40 EST
I see this too with 
localhost:~ -> uname -a
Linux localhost.localdomain 2.6.15-1.1975_FC5hypervisor #1 SMP Tue Feb 21
16:20:41 EST 2006 x86_64 x86_64 x86_64 GNU/Linux
localhost:~ -> lspci | grep ATI
00:0d.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 5c)

If needed I can provide more logs or I/O informations, I will keep the machine
running.

Daniel
Comment 2 Andy Burns 2006-02-28 08:53:07 EST
Oh yeah, inc case it's significant I forgot to mention my card is PCIe

01:00.0 VGA compatible controller: ATI Technologies Inc RV370 [ATI Sapphire X550
Silent]
Comment 4 Rik van Riel 2006-06-26 09:18:40 EDT
*** Bug 196609 has been marked as a duplicate of this bug. ***
Comment 5 Adam Jackson 2006-06-26 17:20:20 EDT
duping this to another x+xen bug with better info.

*** This bug has been marked as a duplicate of 190461 ***

Note You need to log in before you can comment on or make changes to this bug.