Bug 183355 - netdump-server does not execute 'netdump-start' script for RHEL4 GA/U1/U2/U3 kernels.
netdump-server does not execute 'netdump-start' script for RHEL4 GA/U1/U2/U3 ...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: netdump (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On: 183354
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 11:08 EST by Dave Anderson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 07:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Anderson 2006-02-28 11:08:04 EST
+++ This bug was initially created as a clone of Bug #183354 +++

Description of problem:

The netdump server daemon ("netdump-server" service) does not execute
the "netdump-start" script in "/var/crash/scripts" directory when
netdump service is activated on a RHEL4 GA/U1/U2/U3 netdump client.
This is due to a RHEL4 GA/U1/U2/U3 kernel bug in which a netdump client
does not send the prerequisite "[...network console startup...]" message
in the init_netconsole() function of driver/net/netconsole.c.  Instead,
it would send the message "netconsole: network logging started\n", which
is not recognized by the netdump-server.  Although this is being addressed
in the RHEL4-U4 kernel (BZ #177628), to maintain backwards-compatibility
for systems still running the older kernels, the netdump-server should be
updated to recognize both messages as indicative of a client starting up.





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Anderson 2006-02-28 11:13:35 EST
I fixed this in the "upstream" version of netdump (0.7.15-1).
To avoid repeating the nightmare of putting in fixes-without-bugzillas
during the next netdump errata, I'm doing this after-the-fact.

Note You need to log in before you can comment on or make changes to this bug.