Bug 18343 - Installation wants first CD drive
Summary: Installation wants first CD drive
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-04 16:41 UTC by Ulrich Sibiller
Modified: 2007-04-18 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 16:39:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ulrich Sibiller 2000-10-04 16:41:39 UTC
When booting from a 7.0 installation disk to perform an upgrade from a
cdrom drive other than the first one in the SCSI chain the installer
complains about not having found a RedHat disk in _ANY_ cdrom drive
(although is is in the drive already). I have to put the cdrom into the
first drive, then the installer finds it.
I have 2 IDE harddisks in my machine, but no IDE cdrom. The rest is SCSI.
The drive I want to read from has ID 4, the one where RH exspects the disk
to be has ID 3.

It looks like the installer only likes the first drive in the chain!


This problem is not new, I had the same thing with 6.1 and 6.2, and IIRC
6.0.

my /proc/scsi/scsi:

Attached devices: 
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor:          Model: DFRSS2F          Rev: 4B4B
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: TOSHIBA  Model: CD-ROM XM-3701TA Rev: 0236
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 02 Lun: 00
  Vendor: IOMEGA   Model: ZIP 100          Rev: E.08
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 03 Lun: 00
  Vendor: PLEXTOR  Model: CD-R   PX-W124TS Rev: 1.01
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: PLEXTOR  Model: CD-ROM PX-40TS   Rev: 1.00
  Type:   CD-ROM                           ANSI SCSI revision: 02
 
my /proc/scsi/ncr53c8xx/0:

General information:
  Chip NCR53C810, device id 0x1, revision id 0x2
  IO port address 0xd400, IRQ number 11
  Using memory mapped IO at virtual address 0xc8817000
  Synchronous period factor 25, max commands per lun 32
[Profiling info skipped]

Comment 1 Ulrich Sibiller 2000-10-05 13:55:56 UTC
Uups, this is not correct, sorry. I didn't think of the cdrom drive at id 1
(because i never use this one).
Fact is: the redhat cd is not accepted when put in the drive with id 4, in drive
with id 3 it is accepted. 

I will try this again with id 1

My SCSI chain is correct and I don't have any problems with any of the cdrom
drives. The drives work perfectly any time i use them except when installing
redhat linux.

Comment 2 Michael Fulbright 2000-10-05 16:39:33 UTC
The installer looks for an IDE CDROM drive first, then at scd0 best I can tell,
whatever CDROM drive this maps to is the one it uses.


Note You need to log in before you can comment on or make changes to this bug.