Bug 183435 - IBM Thinkpad T41 hangs when trying to shutdown eth0
Summary: IBM Thinkpad T41 hangs when trying to shutdown eth0
Status: CLOSED DUPLICATE of bug 183436
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On: 182466
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-01 02:22 UTC by Jesus M. Rodriguez
Modified: 2014-03-17 02:58 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-03-01 02:26:38 UTC


Attachments (Terms of Use)

Description Jesus M. Rodriguez 2006-03-01 02:22:53 UTC
+++ This bug was initially created as a clone of Bug #182466 +++

Description of problem:
Powering down my IBM Thinkpad T41, it hangs while Shutting down
eth0: (eth0 is configured to be the wired network connection using
e1000).

It also randomly hangs bringing up eth0 to, refer to Bug #182466 for
that.

Because of eth0 hanging on bootup, I disabled network from my init
and let NetworkManager deal with my networking.  If eth0 is plugged
in, everything seems to work as expected.




Version-Release number of selected component (if applicable):

initscripts-8.29-1

How reproducible:

Every time I have tried it so far.

Steps to Reproduce:
1. Power on IBM Thinkpad T30
2. Wait for boot-up sequence to hit the "Bringing up interface eth0"
3. Keep waiting forever
  
Actual results:
System stays hung forever trying to bring up eth0 interface.

Expected results:
System should boot up normally.

Additional info:

-- Additional comment from notting@redhat.com on 2006-02-22 14:54 EST --
If you enable sysrq, and hit sysrq-t (or sysrq-p), what's it doing? Can you
attach all ifcfg-XXX files that you have?


-- Additional comment from rmoseley@redhat.com on 2006-02-22 15:12 EST --
Created an attachment (id=125052)
all of the /etc/sysconfig/network-scripts/ifcfg-xxxx scripts


-- Additional comment from rmoseley@redhat.com on 2006-02-22 15:14 EST --
When I am done updating my system, I will do the sysrq thing and send the results.

-- Additional comment from notting@redhat.com on 2006-02-22 16:11 EST --
Alternatively, you may try booting to single user mode, running 'service network
start' and seeing what it's doing there. (sh -x ifup eth0 may help)

-- Additional comment from rmoseley@redhat.com on 2006-02-22 16:45 EST --
The "sh -x ifup eth0" did it.  I get a bumch of stuf printing out, but here are
the last 5:

+ DYNCONFIG=true
+ '[' -x /sbin/ifup-pre-local ']'
+ OTHERSCRIPT=/etc/sysconfig/network-scripts/ifup-eth
+ '[' '!' -x /etc/sysconfig/network-scripts/ifup-eth ']'
+ exec /etc/sysconfig/network-scripts/ifup-eth ifcfg-eth0

and there it sits forever.  

If I use interactive mode to not bring up eth0 during boot and then run the "sh
-x ifup eth0" command from an x-term, it runs the exact same commands and it
brings the device up.

-- Additional comment from rmoseley@redhat.com on 2006-02-22 17:12 EST --
Hmmm, put a "-x" in the /etc/sysconfig/network-scripts" script and then rebooted
in single user mode.  It appears the script gets hung in a loop that looks like
this:

+ for device in '$3'
+ '[' '' = devxxxxx ']'


I see those lines printed on the screen ad-infinitum.  The xxxxx can be replaced
with any sort of random numbers between 1 and 32767.

-- Additional comment from notting@redhat.com on 2006-02-22 17:20 EST --
If you remove HWADDR=XXX from one of ifcfg-eth1 or ifcfg-wifi0 (why do you have
both with the same, anyway?), does it fix it?

-- Additional comment from rmoseley@redhat.com on 2006-02-22 18:20 EST --
Tried removing the HWADDR= from first one and then both scripts.  The only way I
could get the systm to boot normally was to remove *both* the if-eth1 and
if-wifi0  scripts from the /etc/sysconfig/network-scripts dir.

Good question though.  Why do I have both and they are both trying to set-up the
wireless connection?  Is this actually an anaconda/kudzu problem?  Are those the
guys that create those scripts on install?  Both of those scripts have
"onboot=no" in them, so why are they even a factor at boot-up?

-- Additional comment from rmoseley@redhat.com on 2006-02-22 22:17 EST --
I take that back, my system did hang with just the ifcfg-eth0 script in
/etc/sysconfig/network-scripts.  I had to remove the HWADDR= statement to get it
to boot without errors.  I put back the ifcfg-eth1 and ifcfg-wifi0 scripts too
and removed their HWADDR= statments and the system boots fine now.

Something about those startup scripts does not like the HWADDR= statements, but
after the system is started, you can run the ifcfg-xxxx scripts fine.  The next
question is, why is there both a ifcfg-eth1 and ifcfg-wifi0 script when both try
to start the same device?

-- Additional comment from rmoseley@redhat.com on 2006-02-23 09:27 EST --
Well, let me recount.  Since I came into the office this AM I see my eth0 does
work fine, except I am connected to some wireless network in our building
complex with a 192.168.2.113 address.  It seems without the HWADDR, the bootup
connects the eth0 to the internal wireless card.  Looks like I will have to
resort to either putting the HWADDR statement back in ifcfg-eth0 and boot up
interactively, skip the eth0 device, or leave the HWADDR in ifcfg-eth0 and use
"neat" to deactivate the wireless and activate the hardwired connection after
the system is started.

-- Additional comment from rmoseley@redhat.com on 2006-02-23 09:41 EST --
Well, there is a third option, I set ONBOOT=no for eth0 and ONBOOT=yes for eth1
and all is well, I am connected to the hardwired Ethernet connection.

-- Additional comment from notting@redhat.com on 2006-02-23 10:53 EST --
What did you originally install the system with?

If you have HWADDR in all the scripts, and simply remove ifcfg-wifi0, does it work?

-- Additional comment from rmoseley@redhat.com on 2006-02-23 11:38 EST --
Here are the iso's I used to load the system:

684748800 Feb 20 16:49 FC-5-Test3-i386-disc1.iso
711372800 Feb 20 17:00 FC-5-Test3-i386-disc2.iso
717608960 Feb 20 17:35 FC-5-Test3-i386-disc3.iso
721094656 Feb 20 19:05 FC-5-Test3-i386-disc4.iso
346030080 Feb 20 18:46 FC-5-Test3-i386-disc5.iso

I also had this problem with FC5test2.  I could not get FC5test1 to work on the
T30 so had no change to try it there.

I tried putting the original ifcfg-eth0 and ifcfg-eth1 scripts back with the
HWADDR lines in them and removing the ifcfg-wifi0 script and it still hangs on
bootup on eth0.

-- Additional comment from notting@redhat.com on 2006-02-23 12:39 EST --
What sort of wireless device is this? What's the output of 'ifconfig -a' when
you boot up with everything loaded?

-- Additional comment from rmoseley@redhat.com on 2006-02-23 13:52 EST --
This is the wireless card that came with the T30, it is an internal "mini-PCI
bus" card or something like that.  I have not had any other cards plugged into
the laptop. It is described in "neat" as this:

Intel Corporation 82801 wireless

lspci shows this:

00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge
(rev 04)
00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP Bridge
(rev 04)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #2) (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #3) (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 (rev 02)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio
Controller (rev 02)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW
[Radeon Mobility 7500]
02:00.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller
(rev 01)
02:00.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller
(rev 01)
02:02.0 Network controller: AIRONET Wireless Communications Cisco Aironet
Wireless 802.11b
02:08.0 Ethernet controller: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM)
Ethernet Controller (rev 42)


"ifconfig -a" shows this when I activate eth0(the wireless connection):

eth0      Link encap:Ethernet  HWaddr 00:02:8A:BA:4C:2D
          inet addr:192.168.2.113  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::202:8aff:feba:4c2d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:4728 dropped:0 overruns:0 frame:4728
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:5 txqueuelen:1000
          RX bytes:578 (578.0 b)  TX bytes:3501 (3.4 KiB)
          Interrupt:11 Base address:0x8000

eth1      Link encap:Ethernet  HWaddr 00:0D:60:2D:03:82
          inet addr:172.16.17.234  Bcast:172.16.17.255  Mask:255.255.254.0
          inet6 addr: fe80::20d:60ff:fe2d:382/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6752 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6034 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1962379 (1.8 MiB)  TX bytes:540123 (527.4 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3501 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3501 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6437840 (6.1 MiB)  TX bytes:6437840 (6.1 MiB)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

-- Additional comment from notting@redhat.com on 2006-02-28 14:50 EST --
Created an attachment (id=125414)
Patch for this

Does the attached patch fix it for you?

-- Additional comment from rmoseley@redhat.com on 2006-02-28 16:08 EST --
It does fix the hanging problem, but it does not configure eth0 properly all the
time.  I rebooted 6 times and only once did eth0 come up connected to the
network, the others times I got "Device eth0 has different MAC addres than
expected, ignoring."  Its like the probe for Ethernet hardware gets the wireless
to respond first *most* of the time (which is my ifcfg-eth1/ifcfg-wifi0 files)
and it does not match the MAC address in the ifcfg-eth0 which is the hardwired port.

I did restore the original ifcfg-eth0/ifcfg-eth1/ifcfg-wifi0 files after
patching and before trying all of the reboots.

-- Additional comment from notting@redhat.com on 2006-02-28 18:49 EST --
Created an attachment (id=125430)
patch, take 2

Try this,  instead. You'll need to revert the previous.


Note You need to log in before you can comment on or make changes to this bug.