Bug 183436 - IBM Thinkpad T41 hangs when trying to shutdown eth0
IBM Thinkpad T41 hangs when trying to shutdown eth0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 183435 (view as bug list)
Depends On: 182466
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 21:25 EST by Jesus M. Rodriguez
Modified: 2014-03-16 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: FC5GOLD
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-23 21:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Original network-functions (9.34 KB, text/plain)
2006-02-28 21:38 EST, Jesus M. Rodriguez
no flags Details
Original ifup-eth (9.74 KB, text/plain)
2006-02-28 21:38 EST, Jesus M. Rodriguez
no flags Details
Modified ifup-eth (9.77 KB, text/plain)
2006-02-28 21:39 EST, Jesus M. Rodriguez
no flags Details
Modified network-functions (9.48 KB, text/plain)
2006-02-28 21:40 EST, Jesus M. Rodriguez
no flags Details
Entire network-scripts directory (42.67 KB, application/octet-stream)
2006-02-28 21:44 EST, Jesus M. Rodriguez
no flags Details
diffing network-scripts directories (892 bytes, text/plain)
2006-02-28 22:19 EST, Jesus M. Rodriguez
no flags Details

  None (edit)
Description Jesus M. Rodriguez 2006-02-28 21:25:14 EST
+++ This bug was initially created as a clone of Bug #182466 +++

Description of problem:
Powering down my IBM Thinkpad T41, it hangs while Shutting down
eth0: (eth0 is configured to be the wired network connection using
e1000).

It also randomly hangs bringing up eth0 to, refer to Bug #182466 for
that.

Because of eth0 hanging on bootup, I disabled network from my init
and let NetworkManager deal with my networking.  If eth0 is plugged
in, everything seems to work as expected.
Comment 1 Jesus M. Rodriguez 2006-02-28 21:26:46 EST
*** Bug 183435 has been marked as a duplicate of this bug. ***
Comment 2 Jesus M. Rodriguez 2006-02-28 21:30:12 EST
I enabled sysrq and here are the last few lines:

S         rc: 2360 [f3940aa0, 116] (not blocked on mutex)
S K90network: 2699 [f7e48000, 125] (not blocked on mutex)
R     ifdown: 2725 [f7f65000, 125] (not blocked on mutex)
R     ifdown:20386 [f3940000, 125] (not blocked on mutex)
X     ifdown:20387 [f756d000, 125] (not blocked on mutex)
R     ifdown:20388 [f7c12aa0, 125] (not blocked on mutex)

---------------------------
| showing all locks held: |
---------------------------

================================================
Comment 3 Jesus M. Rodriguez 2006-02-28 21:31:36 EST
After more than 10 minutes, it reads as follows:

S         rc: 2360 [f3940aa0, 116] (not blocked on mutex)
S K90network: 2699 [f7e48000, 125] (not blocked on mutex)
R     ifdown: 2725 [f7f65000, 125] (not blocked on mutex)

---------------------------
| showing all locks held: |
---------------------------

================================================
Comment 4 Jesus M. Rodriguez 2006-02-28 21:38:09 EST
Created attachment 125437 [details]
Original network-functions
Comment 5 Jesus M. Rodriguez 2006-02-28 21:38:50 EST
Created attachment 125438 [details]
Original ifup-eth
Comment 6 Jesus M. Rodriguez 2006-02-28 21:39:45 EST
Created attachment 125439 [details]
Modified ifup-eth
Comment 7 Jesus M. Rodriguez 2006-02-28 21:40:34 EST
Created attachment 125440 [details]
Modified network-functions
Comment 8 Jesus M. Rodriguez 2006-02-28 21:42:34 EST
output of /sbin/ip -o link:

[root@localhost network-scripts]# /sbin/ip -o link
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue \    link/loopback
00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen
1000\    link/ether 00:0d:60:cf:2d:3a brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000\   
link/ether 00:0e:9b:26:77:d5 brd ff:ff:ff:ff:ff:ff
4: wifi0: <BROADCAST,MULTICAST> mtu 2312 qdisc noop qlen 100\    link/ieee802.11
00:0e:9b:26:77:d5 brd ff:ff:ff:ff:ff:ff
5: sit0: <NOARP> mtu 1480 qdisc noop \    link/sit 0.0.0.0 brd 0.0.0.0
Comment 9 Jesus M. Rodriguez 2006-02-28 21:44:34 EST
Created attachment 125441 [details]
Entire network-scripts directory

In case you need more files from network-scripts, I've attached the entire
thing.
Comment 10 Jesus M. Rodriguez 2006-02-28 21:46:08 EST
[root@localhost etc]# cat modprobe.conf
alias eth0 e1000
alias eth1 airo
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
Comment 11 Jesus M. Rodriguez 2006-02-28 22:15:48 EST
While investigating further I observed something truly odd.  I started up the 
"Network Configuration" applet.

1) select eth0
2) click Edit button
3) click Hardware Device tab
4) next to Hardware it showed: eth0 (AIRONET ...)
5) Bind to MAC address showed: 00:0E:9B:26:77:D5
6) Click the Probe button
7) The MAC address CHANGED!! to 00:0d:60:cf:2d:3a

I then verified the eth1 settings, after clicking the Probe button,
it too had it's MAC address changed from 00:0D:60:CF:2D:3A to
00:0e:9b:26:77:d5.
Comment 12 Jesus M. Rodriguez 2006-02-28 22:19:12 EST
Created attachment 125444 [details]
diffing network-scripts directories

This diff reveals that eth0 had the MAC address of the wireless device
and eth1 had the MAC address of the wired device.  This is evident by 
the fact that wifi0 had the same MAC address as eth0.

I would've figured that eth1 and wifi0 should have had the same
MAC address as they are the wireless devices.
Comment 13 Bill Nottingham 2006-02-28 22:31:37 EST
So, if you run 'service network stop', does that also hang?


Does the second patch in 182466 help at all?
Comment 14 Jesus M. Rodriguez 2006-03-01 20:56:58 EST
I applied the patch from bug #182466. After several reboots and shutdowns, all
seems well.  I am satisfied with the results.

AWESOME WORK!  Thanks Bill.

Note You need to log in before you can comment on or make changes to this bug.