Bug 183449 - X-Chat 2.6.1 has been out for almost 2 months, still not in Rawhide
X-Chat 2.6.1 has been out for almost 2 months, still not in Rawhide
Status: CLOSED DUPLICATE of bug 201116
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
http://www.xchat.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 23:53 EST by Kevin Kofler
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-05 19:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xchat-2.6.6-simplify-to-use-gnome-open-for-default-webbrowser.patch (391 bytes, patch)
2006-07-28 13:23 EDT, Remi Collet
no flags Details | Diff
Updated spec file (19.52 KB, application/octet-stream)
2006-07-29 03:23 EDT, Remi Collet
no flags Details

  None (edit)
Description Kevin Kofler 2006-02-28 23:53:04 EST
X-Chat in Rawhide is out of date (2.6.0, 2.6.1 released on January 6th). Any 
chance we'll see it upgraded before FC5 (or at FC5 release)?
Comment 1 Christopher Aillon 2006-03-01 11:17:36 EST
Are you collecting version numbers or is there a specific feature you'd like to see?
Comment 2 Kevin Kofler 2006-03-02 08:19:26 EST
I just noticed X-Chat in particular being out of date. 
http://www.xchat.org/changelog.txt lists several bugfixes and a few new 
features. 
Comment 3 Peter Zelezny 2006-03-02 21:05:35 EST
The slow tree-layout in 2.6.0 would be a good reason to go with 2.6.1.
Comment 4 Bryan O'Sullivan 2006-03-03 00:50:02 EST
2.6.0 is very crashy in rawhide for me, but 2.6.1 is much more stable.

See
http://sourceforge.net/tracker/?func=detail&atid=100239&aid=1441105&group_id=239
for details.
Comment 5 sangu 2006-03-21 06:26:28 EST
Please update for Korean user.

xchat 2.6.0 has only english messages in ko_KR.UTF-8.
But xchat 2.6.1 display Korean translated messages display in  ko_KR.UTF-8.
http://www.xchat.org/changelog.txt
[...]
2.6.1 - 06/Jan/2006
----------------------------------------------------------------------

 - Updated translations (de, el, fi, fr, gl, hu, ko, nl, pa, sq, vi).
[...]
Comment 6 sangu 2006-04-17 11:38:49 EDT
X-Chat 2.6.2 was released -  Please update to new version. :)

http://www.xchat.org/files/source/2.6/xchat-2.6.2.tar.bz2
Comment 7 Nathan G. Grennan 2006-06-22 19:55:31 EDT
xchat 2.6.4 is out and it has spell checking in the input using Gtkspell. It is
a major feature for me. I was able to recompile with 2.6.4 without a problem. A
build requirement of gtkspell-devel and a requirement of gtkspell should be added.
Comment 8 Remi Collet 2006-07-28 13:23:41 EDT
Created attachment 133252 [details]
xchat-2.6.6-simplify-to-use-gnome-open-for-default-webbrowser.patch

Translations are really missing in 2.6.0.

2.6.6 is out with the translations back (de, el, es, fi, fr, gl, hu, ja, ko,
nl, pa, sq, sr, sv, vi and zh_tw).
Build and work fine on FC5.

Diff from spec file of 2.6.0-4
- remove xchat-2.6.0-dbus-api.patch
- change xchat-2.0.9-simplify-to-use-gnome-open-for-default-webbrowser.patch to
proposal xchat-2.6.6-simplify-to-use-gnome-open-for-default-webbrowser.patch

Thank's for non english speaking users.
Comment 9 Remi Collet 2006-07-29 03:23:03 EDT
Created attachment 133279 [details]
Updated spec file

If it can help : a updated version of the spec file with 
- update to 2.6.6
- new patch for gnome integration
- spell checking enabled.
Comment 10 Peter Zelezny 2006-07-29 11:17:03 EDT
The gnome-open patch is silly. It already uses gnome-open (hardcoded) by default.
The Opera option you removed is only displayed as a further option IF opera is
in your path.
Comment 11 Christopher Aillon 2006-08-04 15:40:11 EDT
We also really ought to get the multiline patch in. 
http://cvs.fedora.redhat.com/viewcvs/devel/xchat/xchat-2.4.4-multiline-messages.patch?rev=1.1&view=auto
Comment 12 Kevin Kofler 2006-08-05 19:35:50 EDT

*** This bug has been marked as a duplicate of 201116 ***

Note You need to log in before you can comment on or make changes to this bug.