Bug 183458 - Can't compile vmmon for VMWare-server
Can't compile vmmon for VMWare-server
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 04:51 EST by Brad Hards
Modified: 2015-01-04 17:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 14:15:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hards 2006-03-01 04:51:56 EST
Description of problem: 
After installing VMware-server-e.x.p-20925.i386.rpm (from vmware's website), I 
run the normal vmware configure script. It dies with: 
 
Trying to find a suitable vmmon module for your running kernel. 
 
None of the pre-built vmmon modules for VMware Server is suitable for your 
running kernel.  Do you want this program to try to build the vmmon module for 
your system (you need to have a C compiler installed on your system)? [yes] 
 
Using compiler "/usr/bin/gcc". Use environment variable CC to override. 
 
In file included from <stdin>:2: 
/lib/modules/2.6.15-1.1996_FC5smp/build/include/asm/page.h:71:23: error: 
mach_page.h: No such file or directory 
What is the location of the directory of C header files that match your 
running 
kernel? [/usr/src/linux/include]   
 
Version-Release number of selected component (if applicable): 
Linux version 2.6.15-1.1996_FC5smp (bhcompile@tweety.build.redhat.com) (gcc 
version 4.1.0 20060227 (Red Hat 4.1.0-0.31)) #1 SMP Tue Feb 28 16:15:28 EST 
2006 
 
 
How reproducible: 
Everytime I run vmware-config.pl 
 
Steps to Reproduce: 
1. Install vmware-server beta 
2. run vmware-config.pl (with sudo) 
 
   
Actual results: 
Can't find vmmon compatible, and fails to build because of kernel header 
problems. 
 
Expected results: 
Can't find pre-build vmmon compatible, but builds a compatible one. 
 
Additional info:
Comment 1 Ronny Bremer 2006-03-01 12:17:26 EST
Same here.
Comment 2 Dave Jones 2006-03-01 23:17:02 EST
vmware problem.
Comment 3 Ronny Bremer 2006-03-02 01:07:30 EST
Dave,

are you sure about this? The error msg of the compiler indicates a faulty or
missing include file inside the kernel tree. I am more than happy to bring this
up with vmware, but I doubt there is anything they can do. It worked with
previous kernel releases though, which also indicates a break in the kernel
header files.

Ron
Comment 4 Dave Jones 2006-03-02 01:24:05 EST
stuff moves around/gets deleted or added in the kernel include files all the
time. There is no stable kernel ABI, so out of tree modules break all the time.

vmware's module is written to work against an older version of the kernel.
Comment 5 Thorsten Scherf 2006-03-08 09:46:29 EST
seems not to be a real vmware bug. see this:
http://www.vmware.com/community/message.jspa?messageID=345893
Comment 6 Alan Cox 2006-03-08 09:59:21 EST
Probably vmware should use cpp not perl to evaluate  C header values...
Comment 7 Dave Jones 2006-03-08 14:15:30 EST
either way, It's still a vmware problem, not something we need to fix.
Comment 8 Brad Hards 2006-03-08 14:52:35 EST
I got it working with use of a different installer - use  
vmware-any-any-update98.tar.gz from http://platan.vc.cvut.cz/ftp/pub/vmware/ 
There is a bit more detail on the VMWare support forum pages, but I can't get 
there right now. 
 
Ron: if you are still having problems after reviewing the various options, you 
might like to try Ubuntu - they appear to care about vmware working. 
Comment 9 Dave Jones 2006-03-08 16:15:32 EST
You seem to be under the impression this is a Fedora bug.
The vmware module broke because the *upstream kernel* changed things.
The exact same problem will occur under ubuntu, or any other distro that has a
kernel based on the same base-level as the one in rawhide right now.

Expecting out-of-tree modules to work out of the box with kernel-of-the-day is
totally unrealistic.

Note You need to log in before you can comment on or make changes to this bug.