Bug 183461 - Azureus using excessive memory and CPU
Azureus using excessive memory and CPU
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 05:15 EST by Garry Harthill
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 14:04:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Classes loaded as bytecode (18.19 KB, text/plain)
2006-03-01 05:15 EST, Garry Harthill
no flags Details

  None (edit)
Description Garry Harthill 2006-03-01 05:15:07 EST
Description of problem:
top - 14:24:28 up 5 days,  3:41,  5 users,  load average: 3.78, 3.61, 3.27
Tasks: 117 total,   1 running, 116 sleeping,   0 stopped,   0 zombie
Cpu(s): 57.0% us, 10.3% sy,  0.0% ni, 31.1% id,  1.3% wa,  0.3% hi,  0.0% si
Mem:   1027288k total,  1002144k used,    25144k free,    39564k buffers
Swap:  1020116k total,      940k used,  1019176k free,   405756k cached

 PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
13132 garry     15   0  966m 213m  37m S 50.6 21.3 227:27.00 gij

213m and 50% CPU seems a bit excessive

Version-Release number of selected component (if applicable):
azureus-2.4.0.0-0.20060209cvs_1.fc5
glib-java-0.2.3-1.2
cairo-java-1.0.2-0.2
libgconf-java-2.12.1-2.2
libgtk-java-2.8.3-1.2
java-1.4.2-gcj-compat-1.4.2.0-40jpp_80rh

How reproducible:
CPU and memory amounts vary but it's always high.
Comment 1 Garry Harthill 2006-03-01 05:15:08 EST
Created attachment 125459 [details]
Classes loaded as bytecode
Comment 2 Thomas Fitzsimmons 2006-03-01 11:41:12 EST
Yes, BouncyCastle and Jessie are not natively compiled.  I'll try to get them
natively compiled before FC5 ships.
Comment 3 Anthony Green 2006-03-01 13:41:48 EST
(In reply to comment #0)
> CPU and memory amounts vary but it's always high.

I think the memory usage is pretty much par for the course.  What makes you
think it's higher than it should be.

I'm curious about the CPU usage though.  This is 32-bit?  Tell me a little about
your hardware and what specifically was azureus doing when you noticed a
sustained 50% CPU utilization.

Thanks,

AG
Comment 4 Garry Harthill 2006-03-02 07:48:44 EST
(In reply to comment #3)
> I think the memory usage is pretty much par for the course.  What makes you
> think it's higher than it should be.

When Azureus starts it uses minimal amounts of memory. Over time it increases
until nearly all my memory is used by gij process. Even when all torents are
removed and Azureus is just sitting there it doesn't release the memory back.

> I'm curious about the CPU usage though.  This is 32-bit?  Tell me a little about
> your hardware and what specifically was azureus doing when you noticed a
> sustained 50% CPU utilization.

After running azureus a few times I have noticed CPU utilization is acceptable
and I cannot reproduce this sustained high percentage.

Before it was running for a couple of days. I will leave it running for this
period again and see if CPU becomes an issue.
Comment 5 Thomas Fitzsimmons 2006-03-02 11:34:08 EST
OK, but first please update to:

java-1.4.2-gcj-compat-1.4.2.0-40jpp_82rh
jessie-1.0.1-3

which contain native versions of BouncyCastle and Jessie, two jars critical to
Azureus's operation.
Comment 6 Thomas Fitzsimmons 2006-03-03 18:02:38 EST
Have you tried these new packages yet with a long-running Azureus process yet?

Note You need to log in before you can comment on or make changes to this bug.