Bug 183468 - displays incorrect device size
Summary: displays incorrect device size
Status: CLOSED DUPLICATE of bug 183464
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-01 11:25 UTC by Narasimha Murthy
Modified: 2010-01-12 02:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 17:24:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Narasimha Murthy 2006-03-01 11:25:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
"multipath -ll" displays incorrect size of the device. If the lun size of 4.5GB is created, the DM node for this lun displays size=4GB. This truncation happens because of the type of variable used to assign the size is "unsigned long". MSA LUNs are not created exactly with the user requested size, it can slightly differ from the requested size, so we see the problem of displaying 1 GB less if the LUN size is slightly less.


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.5-6.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
1.Create a LUN size (not integral multiple) of say 4.5 GB, present to a host.
2.Rescan or reboot the host and Configure multipath using "multipath -v3" 
3.view the DM multipath display using "multipath -ll", observe the value of size of the DM device created above.
  

Actual Results:  displays the incorrect device size truncated to previous integral value.

Expected Results:  should have displayed exact size say 4.5GB (in our example)

Additional info:

nil

Comment 1 Ben Marzinski 2006-03-01 17:24:51 UTC

*** This bug has been marked as a duplicate of 183464 ***


Note You need to log in before you can comment on or make changes to this bug.