Bug 183470 - displays incorrect device size
displays incorrect device size
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 06:26 EST by Narasimha Murthy
Modified: 2010-01-11 21:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 15:18:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Narasimha Murthy 2006-03-01 06:26:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
"multipath -ll" displays incorrect size of the device. If the lun size of 4.5GB is created, the DM node for this lun displays size=4GB. This truncation happens because of the type of variable used to assign the size is "unsigned long". MSA LUNs are not created exactly with the user requested size, it can slightly differ from the requested size, so we see the problem of displaying 1 GB less if the LUN size is slightly less.


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.5-6.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
1.Create a LUN size (not integral multiple) of say 4.5 GB, present to a host.
2.Rescan or reboot the host and Configure multipath using "multipath -v3" 
3.view the DM multipath display using "multipath -ll", observe the value of size of the DM device created above.
  

Actual Results:  displays the incorrect device size truncated to previous integral value.

Expected Results:  should have displayed exact size say 4.5GB (in our example)

Additional info:

nil

Note You need to log in before you can comment on or make changes to this bug.